Floodlight stops working

Ok so it’s getting really annoying and I called ring support and they’re useless. Ever since the last AWS outage, my floodlight cam just randomly stops picking up any motion and live view stops working. Then magically it starts up again. I have two whole nights of missing footage from this thing because it just stopped working. Wifi is perfect, in the -50 range and is always up and running, and my ring doorbell works fine as well as my local dvr security cameras. So it’s just this floodlight. When I checked tonight, the lights wouldn’t respond or anything. Nothing worked. However my router showed it was still connected no problem. I did a reset and am waiting to see what it does now, but I doubt that will do anything. What is going on with this thing? Ring support over the phone isn’t helpful at all so figured maybe someone here would be.

Hi @user3215. I’d recommend monitoring your Camera since you’ve completed a reset. You can also walk through a new setup after the reset, by using the steps under Set Up a Device. If these concerns persist, please follow up with our support team so they can look into this further with you. Please give our support team a call at one of the numbers available here and let them know what troubleshooting steps you’ve tried so far and what concerns you’re still experiencing. If you are outside of the US, please visit here to see how to contact support.

Thanks. I called in and they replaced my camera. Now I’m having a new issue where it only detects people if you’re five feet or so from the cam, but won’t detect it’s a person when you’re at the end of my driveway even though all settings are identical to old camera. I made another topic about it. Can’t win it seems.