Floodlight Stopped Working

Our outdoor floodlights stopped working. The app shows they are on, but they are not. We’ve reset it multiple times and still not working. In just looking at the app, it would appear the lights are working properly, however they are not coming on at all. The cam is working fine.

Hi @Sasha14. I would try to power cycle the Floodlight Cam. To do this, disconnect it from power for 3 minutes, then turn the power back on. Then, try to reconnect it to wifi by following the steps in this Help Center article here. I hope this helps!

Thanks for replying Tom.

We tried the steps and unfortunately the lights still are not coming on. We power cycled for 5 minutes and turned back on and reconnected to wifi. We are seeing the same result. The app will show as they are on, however they will not come on.

Do you have any other suggestions?

Thank you for attempting those steps, @Sasha14. When the Camera is online and working as intended the lights should also come on, whether automatically or through manually toggling the lights on in the Ring app. If that is not the case, this may require a closer look from our support team. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

Hi Sasha

Did you sort this issue? I have the same problem

I have the same issue, as do many others judging by how many recent threads there are about this problem. Seems like the LED floodlights are designed to fail after about 1-2yrs of use and Ring refuses to do anything about it.