Floodlight pro fails to continue setup after the phone connects to Ring WiFi network

Title. This is the second floodlight pro I’m trying to install and while the first one went like a breeze, the second installation just doesn’t want to work.

I reach the step where my phone connects to the Wifi-xxxxx created by the Floodlight Pro, the camera light is blinking, the phone IS connected to the Wifi, I’m about 5 feet away in line of sight.

Phone has bluetooth on, location services on, all permissions granted to Ring app.

I tried factory resetting the camera by holding the button for about 10 seconds (the blue led flashes fast for some time then both floodlights turn on for a brief moment).

I tried power cycle it several times.

I’m always stuck in the same setup spot.

Home wifi SSID 2.4 GHz only, strong signal.

I tried 3 different Android phones with Android 13 and Android 9.

I’m at a loss! What else I can try? Given that installing it to the wall was a pain due to really stiff electrical cables at my house I’d rather avoid RMAing it :slight_smile:

Hi @user70099. You have tried all the troubleshooting steps I would have recommended for your concern. The next step is to contact our support team for further assistance. Give our support team a call at one of the numbers available here.