Floodlight Notifications Are Not Snoozing

I have the Ring app on Android 8.1. For the past month or so, whenever I get a Floodlight motion alert on my phone, I tap snooze for 2 hours, but I still get notifications. If I go into the app>devices>floodlight>motion snooze>select duration>snooze motion, then it actually snoozes. Anyone else experience this?

I have tried clearing cache and uninstalling/reinstalling the app.


Same exact issue here.

1 Like

About how long has this been happening to you?

About 2 months. I have even gotten a new phone since, and still doing it.

1 Like

OK thanks. It’s pretty annoying!

Same. Note 10 on Android Q. Ring app is up to date.

Same, and considering how often my kids and dogs play or are out in the back yard, its beyond annoying right now… Happening to both me and my wife, S10, Note10+

1 Like

It is annoying…and as a temporary solution, I’ve changed the detection zone slightly so that when we take out the trash it won’t trigger the alert. I still want the alert for off hours and when we’re not at home, but the snooze function not working from the notification alert is frustrating.

Same issue, on the HD doorbell as well as floodlight/camera. Galaxy 9, latest os and app versions.

Does Ring do there own SW dev or is it third partyed out? Do you use any modern coding practices to make sure basic functionality works? Obviously this is a huge bug that needs to be fixed asap.

A Ring Specialist has reached out to me via email and told me that this issue has been relayed to their development team. We’ll see what happens.

1 Like

This issue has been going on for at least 3 weeks now for my wife and I. I’ve called support and the tech was quite clueless to the option to snooze from the “pop up” choice. After hanging up and talking to another tech, they acknowledge an issue.
Still screwed up and I’m really annoyed with this issue with no response as to a fix. Thinking of changing cameras to Arlo.

1 Like

My hopes are not high that this issue will be fixed after they’ve looked into it. Maybe not until an app update (hoping)?

I have had to turn off notifications on my spotlight cam because snooze no longer works on my pixel 2 XL - Android 10. I have about 500 notifications that my son is playing basketball.

I also have the exact same issue, where snoozing from the notification has no effect, leaving snoozing through the app as the only method of snoozing notifications.

Has there been any update from Ring Support?

Last email correspondence with Ring support was 1.8.2020, and they were still looking for a solution.

1 Like

It’s a mess not having that ability now. I went out and bought some other cameras to try out. To have to shut off notifications for hours because I have dogs that need to go out is a waste of money for me. I most likely will be canceling my ring subscription and sell the ones I have.

I also have this problem. I’ve tried two different Android phones (both Andoird 10) and both are the same, iOS on my wifes iPhone and my iPad seems okay.

Ring is quickly doing downhill in my books, basic stuff like this ruins a users’ experience, and it is likely I’ll end up cancelling also, and migrating to another provider if it is not rectified soon.

If you are snoozing motion detect in the Ring App and still receive Alexa notifications (but no notifications from the Ring App) you need to create a Routine to pause motion detection. To do this;

Open Alexa App
Go to Settings \ Routines
Create a new Routine +
Enter routine name +
Type in routine name --> Pause motion detection
When this happens +
Select: Voice Input
Type in --> {Alexa}, pause motion detection
Add action +
Select --> Device Settings
Select --> Do Not Disturb
Enabled: On
On: Select – > All devices or specific echos
Duration: 2 hours

You now have a routine that will pause notifications for 2 hours on your selected Echo devices.

You just need to say, “Alexa pause motion detection”.

Now go shovel your driveway, shoot baskets, wash your car, move stuff into your house without annoying the heck out of everyone in your house.

You will still get notifications on your Ring App unless you snooze there as well. My Ring App notifications are a vibration so I don’t care…

I have 2 Ring devices; HD Pro Doorbell and LED Floodlight camera.

1 Like

Perfect! Exactly what I needed to do. I was going to say that Ring app will pause notification on my phone, but the rest of the Echo devices in the house keep going. On a windy day like today, it drives me nuts. Thanks.

1 Like

Same issue with my Stickup Cams.

As of the last month or so, the ability to snooze notifications from the phones notification bar no longer work. Only solution for now is to open the Ring app and snooze them from there. Running Android 10 on a Pixel 4