Floodlight camera will not go into setup mode. Useless at the moment.

Seems to be a recurring theme here. The camera first came up and even recorded me on the ladder. But then it lost comms, lights stayed on, etc.

Tried single press, 15 second press, 30 second press, disconnected power for 8 hours and tried it all again. Nothing allows it to go into setup mode. It does nothing but mock me with the floodlights on all the time. I’ve had several others up and running for a couple of years with no issues.

I tried chat and it tells me that you don’t answer for setup questions. I’m hearing impaired so calling you on a phone is not an option. I need either a chat option or an email option for support.

Thanks.

Hi @jcobbjr. Our chat team is unable to do troubleshooting like what you’re looking for at this time. The only team that’s able to do this troubleshooting is our support team over the phone, so I recommend being in contact with a third party service who could be the translation for you to call in for you and speak on your behalf. Once you have this in order, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. They will ensure they do everything they can, and if they cannot get it set up with your still, they will replace it if you’re still within warranty.