Floodlight camera has no live view or recordings

Installed floodlight camera, installation and setup went smoothly and firmware shows as updated. I’m getting notifications of motion detection and it shows snapshot on the home page but when I go to review the footage it tells me that the Recording is unavailable and when I try to do a Live View it tells me it has Failed to connect.

I have tried factory reset, I have tried unistalling and reinstalling the Ring app. I contacted Ring Help and they couldn’t tell me why it wasn’t working. After working with them for a couple hours they said it showed on there end that the firmware wasn’t updating though my app said it was. They said they would contact me later about it but after a few weeks I haven’t recieved anything from them.
Since I’m not getting much help from them anyone have any ideas on what to try?

Good call on reaching out to our support team, @UserM400! Although you’ve likely covered just about every step we would recommend from our Live View troubleshooting post, check out the steps there to see if any might work. Please also ensure there is not a VPN enabled. If possible, try another mobile device entirely to see if live view connects there. Your recordings should also show at Ring.com, as long as you are subscribed to a Protect Plan. Feel free to let us know how this goes! :slight_smile: