Floodlight camera cannot setup

I setup Floodlight Cam today, it worked fine first a few minutes, then it lost Internet Connection, I try to bring back online, but no luck so far.

then I delete the device from ring app, try to add back again, It seems Cam cannot enter setup model, the light always on, I tried to hold top button 20 seconds to reset but did not work, try to hold firm and quick release to trigger setup model did not work, power off and on, no change. led no flash

the light always on when power on.

do you have any idea what is wrong, or should I exchange to another one, does this cam has some issue?


Hey @Jackxur. Thank you for taking the time to let us know what steps you’ve tried so far and how that’s worked for you. Since you’ve reset the Floodlight Cam and it is not going into setup mode, please try giving our support team a call at one of the numbers availablehere. They’ll be able to take a closer look at your device and offer more advanced troubleshooting steps. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19here to see how to contact support. Feel free to report back on what support recommends, as it may help other neighbors with a similar concern! :slight_smile: