Floodlight Cam Wired Pro no longer working

Hi all,

Recently bought the entire suit of Ring products including the floodlight cam wired pro. The first one I bought simply didn’t work - no power at all. I got a replacement, which worked for a day and now I get an offline message. I tried to reset it by pressing the button (which, by the way, is no mean feat as it’s installed really high up), and tried to cycle it through the breaker. No light. Do not think there was a power surge or anything - anyone have any suggestions clue? Surely it can’t be a second dud device?

Thanks!

Hi @PH. When you reset the Camera, did you do a full reset by holding down the setup button for at least 20 seconds? If you haven’t tried this yet, I’d recommend giving that a try and then setting it back up in the Ring App. If it still is not responsive, please give our support team a call at one of the numbers available here so they can take a closer look and troubleshoot further with you. If you are outside of the US, please visit here to see how to contact support. :slight_smile: