Floodlight Cam Pro Wired Connectivity Issues

We had a regular floodlight cam wired for about a year and a half on cable internet. Worked great. My wife’s employer moved her to remote (she’s a telehealth provider) so I got second one for the other side of our house and we had fiber internet installed with an eero mesh system about a year ago. We also have two ring doorbells and a ring floodlight. When we installed the mesh wifi, I couldn’t ever get the regular floodlight cams to work after months of trying and reddit threads on pausing the 5G and changing the whatsit, putting it right next to the eero device, etc. and nothing has worked. Other devices never had an issue.

So I had read on some of those forums that the floodlight cam wired pro didn’t have those issues. and finally broke down and bought one for Christmas.

So I get it put up, start the setup process, it picks up the network and gives a green signal indicator, and I click the “join ring-abs321” and it says that it’s “connected to the ring app”. Then I enter the wifi password and it says that it will take a few moments to connect and the circle starts to spin. Just about 15 seconds later it says that my “device may be too far from the router”. But even when the router is right next to it, it still won’t connect. Same as the other two floodlight cams.

Is there anyone here that knows how to help? Would really appreciate some direction!

Hi @jclarksutton85. What type of phone are you using for the setup, and what version of the Ring app is installed? Are you connected to a 2.4 or 5GHz network? As a test, try connecting the Floodlight Cam Pro Wired to a WiFi hotspot. If you can connect to this hotspot, there may need to be some adjustments made to your network. Also, when the connection fails, do you notice a specific light pattern from the bubble on the Floodlight Cam? This could point us in the right direction.

I’m using an iPhone 11 and our eero is 5G, but I have temporarily put it to 2.4 only for setup. The Ring app version is 5.55.0.

I will try the Wi-Fi hotspot idea and see if that works and report back.

The light when it won’t connect blinks a light purple color almost.

Thank you for your help!

Hi @jclarksutton85. Thanks for getting back to me. With a Blue Flashing Light, you’ll want to check some settings on your phone. Go to your Settings > Cellular > WiFi Assist and turn this setting off, just for setup. Also, make sure you are using a alphanumeric WiFi password, as special characters may be causing an issue as well. Let me know if this helps.