Floodlight always on

I just installed the floodlight, but no matter what we do it will never turn off. I have set the manuall “off” on every app this is synced to, and it will magically come back on. I’ve even turned them all off, while each device (2 iphones and a Windows machine) were sitting there in front of me, and watched one, then all of them turn back on all by their merry selves. I’m just waiting for my HOA to throw a hissy fit, please remove this awful feature or patch it.


Followup - as I’m sitting here typing this. The light option on the Windows app is going off, on, off, on…etc. Just doing it by itself. I’m not prompting it. None of the other connected devices have the app open. I’ve set the light zone settings all the way to minimum, and unless there’s ghosts then nothing should be tripping them.

Hi @DoctorMBot can you please clarify which Floodlight this is happening on?

My flood light cam also turns on by itself and stays on longer than the time setting. Please help us Ring

I’m havin this same exact problem. I turn the floodlight off manually and within a minute it turns back on. There are no motion notifications.

Exact same issue. No matter what I do, the light is triggered and on. Please help!

I’m on the phone with Ring support right now about this, finally got tired enough of it to actually call them although I’ll probably just try calling Costco’s concierge instead because they’ll probably be more helpful and I may even just end up ripping all the Ring products out and return them because of all the issues.

I have two floodlight cams, one in front and one in back. I know both of them do this, but I see the one in back more often because it is directly above my bedroom window. Both floodlights come on completely at random and stay on for the time they’re set, I believe 1 minute, then shut off. Then come on again. Then off. Then on, completely at random. I don’t get any motion alert notification on my phone when they do this and it doesn’t record any video and there is no motion outside taking place (it does give motion alert notifications and records when there is real actual motion taking place). The one in front is linked to motion from the doorbell, but no motion alert or recording happening on the doorbell or floodlight when the light randomly comes on. Back floodlight is almost directly above my outdoor air conditioning/heat pump condenser. On the camera motion zone, I drew the boundary around the condenser so it doesn’t see the motion of the fan spinning. Ring support is telling me that it’s detecting a heat signature so I need to relocate the floodlight, but that doesn’t explain why I’m not getting notifications, recordings or why the same issue is happening with the front floodlight where there is no condenser.

They asked me to factory reset one so I had to climb up a ladder and reset it. Then they said to turn off bluetooth and mobile data on my phone which I was talking to them on using a bluetooth headset and when I tried turning mobile data off, it gave a notification that mobile data is needed even when using WiFi calling and when I told it to turn off mobile data anyway the call was disconnected and they haven’t called me back.

I was also mentioning another frequent issue I have where I cannot reliably connect to any of the cameras including the doorbell. Sometimes it connects just fine and pops right up, other times it’ll just refuse to ever connect at all and when it refuses to connect (just stare at an “activating device…” message with spinning circle then eventually get “Live view ended” with a Reconnect button). They said my doorbell for example which is just about 4 feet from the router on the other side of the wall is only getting around 900 Kbps connection and minimum required is 2 Mbps so they suggested routing it through my Chime Pro which is at least 40 feet from the doorbell, so 80 feet round trip and having to relay through an additional device as if that makes any sense at all. I complied with their request and doorbell said it was updating and to wait until the lights stops flashing (light was not flashing). After several minutes it finished and now says it “has a weak Wi-Fi connection” which is only showing 2 of 4 “bars”.

I’m very tempted to just get rid of it all and switch to Nest. Very glad I bought from Costco.

I did receive emails through Ring support. My problem is similar to some others. Turn light off on the app but it turns on without motion. All the bugs are currently frozen and the wind is calm so it is not a constant motion that keeps the light on, rather it seems to start in motion mode but then switches to ‘on’ mode. Now it’s mostly turned off at night just to keep the light off. Looking for some Ring resolution for this.