FloodCam issues

It seems like my floodcam wired only connects when I am right underneath the camera and would connect for at most one hour and gets disconnected.
I talked to the Ring Rep and tried all types of procedures

  1. Connected on 2.4ghz / with good wifi signal as well as 5ghz and since modem is about 6 feet apart where camera is with few drywalls between, device health has been great.
  2. Tried other Floodcam thinking it’s defective, still same issue.
  3. Rewired, still same issues. Tried electricity pen and seems all the wires are hot except the ground.
  4. I have a wired doorbell and it never gave me a problem with connection where the modem is sitting between the bell and camera.
  5. One thing I’ve noticed that was the breaker to the camera also controls our kitchen ceiling lights and the lights seems to be flickering time to time. Bulbs are LED and fairly new with few months old (60W). I don’t see any loose feelings on the breaker when I flip the switch.
  6. Since the WIFI channels were mostly occupied with 6 and 12, I put myself on channel 5 to see if that was network interruption. Which it didn’t seem to change anything.
    Any suggestions I could try?

Hi @user8216. Can you clarify what you mean when you say that your Floodlight Cam only connects when you’re under the Camera? Are you referring to the Live View specifically, and if so, what type of error message are you receiving when you try to access the Live View? Feel free to share any screenshots that demonstrate what you’re seeing in the Ring app.


Its my another modem that i am trying with my isp. But it would generally connect when i am right under the camera. Sensors would sometimes catch up when my garage door opens. But generally the flood wired cam would not be connected more than an hour at most. Usually gets disconnected within 10 min

@user8216 I see in the screenshot it shows that the Live View ended, does it reconnect if you tap Reconnect? What is the RSSI for your Floodlight Cam? You can find the RSSI on the Device Health page in the Ring app. I’m trying to help you narrow down the cause of this concern, as Live View and connectivity problems can vary widely. We do have a wide range of troubleshooting steps for Live View in our Community Post here as well. :slight_smile:

It does not. The RSSI has been great. It does not reconnect. It seems like its the power issue after testing it. Power seems to go in and out

If you’re seeing that the power on the Floodlight Cam itself is going in and out, then there may be something going on with the wiring. I’d recommend consulting a qualified electrician to look at the wiring and safely ensure everything looks good. They may need to replace a stripped wire, or something could be loose.