Fix For Live View useing Firefox Web Browser - grant Microphone permission

As many of you are probably suffering from the same problem I have been since the “Desktop App” disappeared, I thought I would post a solution I found to fix live view when using Firefox.

Symptoms:

  1. When using Firefox, after clicking “Live View”, a popup window shows with “Activating Live View” but activation never happens.

  2. A notification to “Enable Microphone” is seen and when doing so Live View still doesn’t work.

  3. You are able to watch your recorded Live View attempt in your History shortly after your Live View attempt.

A user named @5150Joel had a similar issue for Google Chrome users in this topic. Based off Joel’s findings I though I would see if I could apply something similar to Firefox.

Now this is just what worked for me, this is by no means a in stone solution for everyone, but as of now I’m able to Live View in Firefox with no issues.

Based off the solution in this support topic on the Mozilla support site, this is what I did.

Granting permission through one of the following methods:

(A) Check for a prompt at the left end of the address bar

If the site has asked Firefox for camera/microphone permission, there may be an extra icon next to the lock. Click that to see whether you can grant permissions there.

(B) Use the Page Info dialog

While you’re on the site, either of these 3 ways to bring of "Page Info"

  • Ctrl + i
  • (menu bar) Tools > Page Info
  • right-click a blank area of the page > View Page Info

In the Page Info dialog, click the Permissions icon at the top.

On that panel, scroll down to Use the camera and (A) uncheck Use default and (B) click the permission you want to give the site. I chose “Allow”.

Repeat with Use the microphone .

Then you can close this dialog (it saves as you go and there’s no save button to click).

I then refreshed the page and live view worked. hopefully Ring doesn’t break this fix in some future update. Hope this helps someone.

1 Like

Thanks for this information @Ringgetittogether!

1 Like