Fix for Live View not working from Ring's website-grant microphone permission

Wanted to share what fixed Live View not working in Google Chrome from Ring’s website.

Once you’re logged into Ring.com, click the padlock in the top-left of your address bar and select Site Settings. Locate Microphone in that list and change it to Allow. Refresh your tab for your Ring account and Live View should load afterwards.

For weeks I couldn’t get Live View to load after logging into Ring’s website on any of my cameras. I had no problems at all hitting Live View from any other device/android phone/iPhone/Ring desktop app from anywhere else, inside or outside my network.

I thought I’d try from my wife’s laptop instead of my normal desktop. As soon as I tried Live View from her laptop, Chrome prompted me to allow permission to the laptop microphone. Once that permission was granted, Live View worked fine for all my cams.

Returned to my normal desktop and checked the site permissions for Ring.com in Chrome and granted permission to the microphone (permission was set to Ask). After that, Live View now loads immediately on all my cameras from Ring.com.

I don’t even have a mic’ on my main desktop, but it seems the Win10/Chrome Mic’ permission must be granted for Live View to load. I remember the Ring desktop app prompted me for the permission as well at one point.

15 Likes

Hi @5150Joel. Thank you for sharing this tip! A lot of neighbors may not see the notification for the permission or their browser won’t give them the notification, so this is a great tip to have them check it if Live View isn’t working on desktop. :slight_smile:

1 Like

Great find, as I was was going to quit Ring, as Live View only worked on the “death sentenced”, desktop app, not cellular or from web browsers. In my case the microphone permission was set to never ask.

I am still disappointed in Ring as it appears, there are new Live View issues, probably related to 5G. I’m sure their engineers know these issues, probably are working on them, but users are left in the dark. I think they need to share this type of info to let users know they care about getting resolution, even thou, issues like this, having to work with different companies, maybe reluctant to make changes, possibly due to security issues may not be a quick fix. Users feel ignored, Cellular Live View worked great for many years and some event happens, all existing Ring troubleshooting steps are followed with no resolution. I just need to hear that they are aware of some issues, and working on them, kinda like Microsoft does with their WIN 10 updates notifications.

1 Like

5150Joel -

I think it’s great that you made the discovery and took the time to notify Ring community members.

I hope that Ring engineers, however, don’t consider your discovery a “fix”… as no user should ever be forced to grant microphone permission for ANY reason including, but not limited to, as a requirement for being allowed to view live videos.

1 Like

5150Joel – Thank you for sharing your discovery!

1 Like

Thank you so much for posting this!

I was really aggravated, having the same problem, but this fixed it.

To any further readers, just make sure you are on your “Dashboard” page with the when you make this change because it only affects the page you are currently on. It is not a global change for Chrome.

3 Likes

Thank you so much for this info. It was driving me batty.

4 Likes

Thank you! This finally solved my problem with live view!

2 Likes

Thanks for this. Worked for me. Hard to believe Ring isn’t making this known.

@5150Joel Thanks, worked perfectly on Win10/Chrome.

2 Likes

Joel you are the man! You have done what Ring tech support cant seam to do. Ever since the Ring “Desk Top App” went bye bye I have been forced to use Google Chrome as the way to view my cameras while on my PC. Everything has been working well with Chrome up until about a month ago, the live view popup window would just site at “Activating” and never activate. As Joel stated, I too was able to view my cameras on mobile devices with no issue. When viewing my cameras on Chrome I could replay the old recorder history just fine. I could also attempt to live view, even though it didn’t actually “live view”, I was able to go back into the history a short time latter and watch the recorded attempt I made at a live view. The weird thing is I would always get the notification to “Authorize Microphone” withing the Ring live view window. I would grant access and it would still never activate. @5150Joel Doing it the way you have described here fixed it right away! I thank you sir for going above and beyond to help the Ring community and taking the time to do so.

On a side note…

This is addressing Ring directly.

RING! When will you support Firefox! I’m using Chrome because its my only avenue to view my camera on PC. My browser of choice is Firefox and has been for decades. Lets get it together RING! Things seam to have gone only down hill since I purchased my cameras. I have been considering selling them and getting something better.

WOW! I just found the solution to fix Firefox Live View, used a similar method as this post suggests. I’ll create a new thread with the details.

2 Likes

Didn’t work for me. Still have the same problem on my PC: Live View not Showing.

1 Like

This did not help me unfortunately. I even shut down the browser and restarted. It just endlessly says “Activiating Live View” with the animated circle. Works on ALL other devices flawlessly … TV’s, Echo Shows, smartphone, etc.

1 Like

Hi @timoteo. What browser are you using to Live View with? If you open the browser on your smartphone and go to Ring.com, are you able to use the Live View there? If so, there may be some additional setting within your browser that your need to adjust. Be sure that you have the latest version of your browser installed and that you do not have an active VPN running. Let me know how this goes!