First generation stick up camera won't show local network for setup

Not sure what’s wrong with this camera. It worked before but somehow lost connection to my router. When I try to re set up, I get this message to ask to join network. when I tap the thumb print, i get nothing. Cant use maunal set up either because the local network doesn’t sho up in my networks.

Hi @finiteguy. If you are not able to complete the setup of your Stick Up Cam, try the following steps:

  • Verify your Ring app and phone are updated with the latest versions available.

  • Factory reset your Camera by pressing and holding the setup button for 20–25 seconds, and then go through the reconnection process.

  • Reboot your router by unplugging it from its power source for 10 seconds, then plugging it back in.

  • Try doing the setup using another device like a phone or tablet.

We also have this Help Center article here with other steps to try if your in-app setup is failing repeatedly. If you have tried these steps and are still having the same concern, give our support team a call at one of the numbers available here for further assistance. If you are outside of the US, please visit here to see how to contact support.