First Gen Doorbell fault

Hi all!

I have a first gen doorbell that’s now 2 years old. A few weeks ago it dropped offline and I’m now trying to get it sorted.
I have tried to reconnect it through the app but the doorbell just has a constant flashing blue light, won’t enter setup mode and won’t perform a hard reset.

Any ideas?

Thanks in advance

Hi @Gh0st2602. Have you tried to reset the Doorbell? To reset it, you’ll want to hold down the setup button for at least 20 seconds. After this reset is complete, you can try to reconnect it to wifi by taking it through a new setup in the Ring App with the steps under Set Up a Device. If the setup is unsuccessful, I’d recommend following up with our support team so they can take a closer look.

You can give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. :slight_smile: