First Gen Doorbell fault

Hi all!

I have a first gen doorbell that’s now 2 years old. A few weeks ago it dropped offline and I’m now trying to get it sorted.
I have tried to reconnect it through the app but the doorbell just has a constant flashing blue light, won’t enter setup mode and won’t perform a hard reset.

Any ideas?

Thanks in advance

Hi @Gh0st2602. Have you tried to reset the Doorbell? To reset it, you’ll want to hold down the setup button for at least 20 seconds. After this reset is complete, you can try to reconnect it to wifi by taking it through a new setup in the Ring App with the steps under Set Up a Device.

If the setup is unsuccessful, I’d recommend following up with our support team so they can take a closer look. You can give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

Having the same issues here, what advice did you get from Support?

Tia
Gee46

Hi @Gee46. If the in-app setup is not working for you, try the troubleshooting steps in this Help Center article. I’d also recommend completing a reset by holding down the setup button on your Ring Doorbell or Camera for at least 20 seconds. Once that reset is done, try walking through the setup process again in the Ring app.

If these troubleshooting suggestions don’t work, please reach out to our support team at one of the numbers available here for further assistance. If you are outside of the US, please visit here to see how to contact support.