Firmware not updating - Doorbell Pro


I have 2 Doorbell pro that I installed last week. One of them is not receiving the update and is still on FW 1.16.00272, while my second doorbell is at 2.1.01005

We tried few things with Live Chat, but it was useless as the FW still not updating.

Hi there, @Fredou! Have you tried removing the Ring app, rebooting your phone (turn it off/on), and then reinstalling the app? Maybe then the app will show the updated firmware, but if your device is functioning properly, it may just need a little while longer until it updates the firmware on your other Pro. If you have any other questions, concerns, or want us to take a deeper look into it, it would be best to give our support team a call at 1-800-656-1918!

I read where the newer firmware 2.**** has issues and RING is not downloading it now. Maybe true or stall tactic

I have the 2.1.01005 firmware on my Pro. The device health information shows the number, not “up to date”. My device now has the annoying habit of switching to night vision despite the fact that my porch is extremely well lit. Sometimes all it takes to trigger the night vision changeover is walking in through the doorway after sunset. Then, whammo, the pro switches to barely useful night vision for the remainder of the night.

I have the same issue. Firmware shows number. I have updated phone app as well as shut off power to the device.

Is 2.1.01005 the latest firmware?

Mine says up to date after last week. The instructions state if it says up to date, then it is. It took 4 weeks for mine to update one night.

Yeah mine still has the version number