Failed Yale z-wave lock

I have on hand a failed Yale z-wave lock that I can not remove from my alarm system. Change batteries, tried the 9-volt battery under the keypad. It is just dead. I called Ring support and that was useless and almost nonexistence. I tried using the ring app in advanced options under “Remove failed device” that didn’t work. I’m using the Ring Alarm Pro and tried going that direction and hit a wall there too. So Ring support told me to call Yale to either to get it working or help get it removed. Called Yale and was sent to voice mail for them to call me back. Never got the call (maybe to busy with other failed locks). So Ring an alarm system that allows 3rd party devices but yet don’t have the means to removed them when they totally fail. I really can not see the logic in that

Hi @gulfdigger. Here’s something that you can try. First, reboot your Base Station. Next, you’ll want to follow the steps for “Removing a Z-Wave device”, found here. These are steps for removing a Contact Sensor, but the process is generally the same. When you see “listening for a device”, put your Yale lock into pairing mode. You can also try performing a factory reset on the Yale lock per the manufacturers directions. I hope this helps.