Event History won't play

My event history won’t play, I used my Samsung Galaxy S8 to set up my ring about a year ago. Last month I became unable to view event history videos. I have uninstalled the app several times, turned off phone, restarted phone, reinstalled app, removed or disconnected my device from the app and then reinstalled, connected and disconnected from wi-fi. Still not working on my phone, I added my husband’s phone as a user, same phone as mine, he is able to view event history videos. Installed the ring app on my ipad pro today, I am able to view event videos on it as well.

This is very frustrating to me, I am at a loss.

TBH my Samsung A5 Phone has never been able to view history (nor live events for that matter) only stills from earlier events. Neither wi-fi or data.
My Galaxy tablet S4 is fine - which is OK when I’m on wi-fi, but it has no data capability.
Both devices have latest possible Android updated.

I have a secure Cam and a doorbell. The external cam plays up every now and then - but that’s a different topic.
I’ve had a busy year so no time to follow this up until now.

I am having issues viewing the event history with my Samsung galaxy s10 as well. It’s been two days now.

I am having the same issue where my event history will not play on my ring app on my Iphone. My boyfriends app is working just fine. I can view the live view without any problems. It has always worked fine but the last few weeks the event history will not play. I have tried re-installing the app, the app is up to date. Nothing has fixed it. Does anyone have any solutions? The main reason I have this doorbell is to see whats going on around my home.

I am quite surprised that Tech support or anyone qualified hasn’t provided a resolution to this ongoing issue which is affecting multitudes of current clients. It is a necessity that we have access to this data which atm we do not. I have tried deletion of app with a reboot which didn’t accomplish anything. After a couple months of having this app, I find it glitchy and not very reliable. Disappointed to say the least.

1 Like

Hi @sb3. Your Event History should definitely be working as intended. If not, we’ve accepted our previous post in this thread as a solution for the best steps to take. When viewing this thread, click the “Go to solution” in the top right to be taken straight to our solution.

If the recommended steps do not resolve your Event History concern, please reach out to our support team for more in-depth troubleshooting.

It’s completely false that this is still a valid solution to reinstall the app. I’ve done the process twice now with no success on an iPhone 11 which is up to date. I can’t view any video after March 31st. There is clearly an issue with multiple customers and your response that the accepted solution is posted is completely tone deaf. How about raising this to a higher level support for additional review… that would be an acceptable response for all the customers posting the same issue.

Its not solved by any means. My Samsung Galaxy S10e does same thing. Also i just upgraded my ISP service to faster service and after resetting EVERYTHING it tells me “your connection is very weak” lololol what a joke!

Same here. I have an iPhone11+. I can’t play history dated after 3/29/2020. I also can’t access Live View. I’ve re-installed the app and phone is up to date.

I’ve had this happen once before. Only way I fixed was to remove the doorbell completely and add it back to the account. You will loose your history and currently stored videos but it will work then. I’ll do it again some time this week. It’s obviously an issue that Ring does not want to own up to directly in the forum. They will have you call in and repeat what you have already done via their support script then likely direct you re-add the device.

Issue resolved with the help of Ring support. I reset the wifi on the Ring App and everything works again.

1 Like

Thanks ?? Worked for me just now. Still can’t view events between March 31st and before I re-added my wifi. New events now work. One thing I noticed is a firmware update started right after joining the same wifi again.

1 Like

How do I automatically get each history video recording to play- one right after the next without having to go down to the history text list of next recording… click on that… go back up to the top to play that video then repeat to watch each video recording?

is there a way to change settings so each video recording will play one right after the next?

And can I choose a setting to play all video cameras one right after the next in order of timeline date sequence

And can I change the settings to just play one camera timeline sequence one right after the next?

Please send response to my email address so I’m sure to get it Thank you


reinstalling the software will get easier, as you will need to do this ALOT. it’s very unstable.

Almost a month now and I can’t access any of my event history! Called support 3 times, keeps saying a tech will contact me. Regardless of the shared user and which mobile device we try to view it from.

I started having problems playing videos and didn’t believe it had anything to do with my WiFi … so I deleted the app and downloaded it again that did not work … then I deleted each device and reinstalled them and that did the trick … no problems now

1 Like

I have been waiting to get a solution from the support team since three weeks ago. It is obviously Ring’s responsibility that the device is not working. It is unreasonable that I can’t see who ring the doorbell and the event history.

This just started happening to me too! As of the other day you were able to play one right after the other without having to bounce back to the list of events.

@Marley_Ring can you report this?

1 Like

I have also started having this problem with only one of the devices not playing event history. There is no issue with wifi or network. Until yesterday ‘live’ wouldnt play but now only event history has the problem. I have uninstalled/ rebooted and reinstalled as advised but it is still not working. Is there a solution yet? Otherwise it is pointless playing for a plan when only live mode is working.