Event history timeline causes live view to freeze on samsung s10

History Timeline feature setting is not working on my Samsung s10+ or Samsung s9. It freezes on the live view screen with the words ‘motion detected’ in yellow and then nothing works… The app then freezes and I need to restart. I’ve deleted app and reinstalled it, deleted the cache, restarted the phone and disabled bluetooth but nothing works. It’s not the devices or network as the feature works perfectly on my mothers iPhone. I paid the subscription for this feature specifically it’s a serious problem if it does work. Please resolve ASAP

Thank you for sharing your experience with us @AHR! We value our neighors’ feedback and will certainly share this with the team for further investigation. As you’ve factored out network and device variables, as well as tried on another mobile device, this really narrows down to the best area of focus.

Please ensure the VPN is also disabled on your Samsung and uninstall any android apps that can conflict with the Ring app. You’ve done quite a bit to optimize mobile device performance and connection. Feel free to include any error messages you might receive or further observations related to this concern. In addition to the above steps, try also resetting your mobile device network connection manually, and ensure features like data saver or not enabled.

Hi Marley,

Thanks for your reply. Unfortunatley none of the steps you provided resloved the issue. I don’t have any of the apps that concflit with the Ring app and I reset my network settings but I am still getting the same issue. I have attached a print screen of what I am seeing each time I try to go into a device. It stays like this until the app crashes. Looking forward to you finding a solution. Thanks

I have one of the fastest fiber connections in the united states and it does the same thing here. This is actually quite common for the last several releases of the ring app. On Android I have to wait quite a while for it to timeout, then force kill the app, then try again. It usally works at this point, but you waste about 2 minutes getting into the app. It’s been reported all over the forums and they just aren’t fixing it at this point.

What happens when you use the Rapid Ring App @madfukez ? Also, please take a look at our Community Guidelines and pick a more approrpiate username. If you do not, we have the right to ban you from the Community. Thank you.

@Jennifer_Ring It happens just as described above. It locks the whole phone when the app freezes on open, and just have to wait. It wont show the cameras when it does finally load so I force kill it. Once I start it again it works fine.

Looks like I did a typo on my username and should be madfuskez! It’s not offensive, really. :slight_smile: How can I change it, or can you change it for me? I don’t see any way to do it in my profile.

@jennifer_ring When I use Rapid ring the device opens up and works but the audio is not coming out of the phone speaker but the in call speaker. I have to hold the phone to my ear to hear the sound and then loose visiual. It getting really frustrating.

Also as soon as I shift to live view on the Ring App it crashes. I’ve tried everything to get it to work including deleting the app and reinstalling but it just doesn’t seem to be working. It still works on the old IPhone we have but on Andriod it isn’t working. Do you have an update on when this is going to be fixed becuase it seems as though many people are having this problem.

@madfukez @AHR Could you please try capturing the crashing of the app via screen recording? Once you have this screen recording we can take a deeper look into this for you! Also, please let me know what phone you have, what software the phone is on and the app version you are running (after ensuring it’s most up to date, please post the version for me if you can to confirm it’s up to date!).

@AHR For your audio concern, do you have any bluetooth devices connected when you are trying to do this? This may be why the audio is having to be outputted from a different area.

@madfukez If you click on your picture at the top right and then click on My Settings, you can change your username from there! :slight_smile:

@Chelsea_Ring I cannot find a way to private message you so sorry i have to post this in the main thread here. I’ve looked through every single option in my settings and don’t see an option to change it anywhere. Could this have been removed?

@Chelsea_Ring I posted a screenshot earlier of what happens when app freezes. I’ll attach again here. As for the phone I am using a Samsung S10+ with the latest Andriod 10 Software updated.

Also, I do have a watch that is connected to my blue tooth but even when I turned bluetooth off it still had the in call speaker problem.



@madfukez Could you send us an email at community@ring.com and we can get this username concern sorted out for you! Feel free to email us with your desired username from the email address you use for Community. :slight_smile:

@AHR Are all of your videos from Ring.com also a black video, or from the other iPhone you used before? Let me know if the app or website also show the videos as all black or if you can actually see the video!

Hey @Chelsea_Ring on the desktop app and the iphone the video works fine. The event timeline on the Iphone works fine. Its just the andriod devices that it does not work. I tried using another andriod device, Samsung S9 with adriod 10 and it has the same problem. I think you guys might need to do an update for the ring app on andriod.


@AHR Could you capture a screen recording of what happens on the Android app, where when you pull up the Timeline view the videos are black? I have not seen reports on this, so getting this looked at and escalated up will require a video like that to explain and see why this may be happening on one device and not another. Also, for the Android app, could you try removing the Ring app, rebooting the phone and then reinstalling the app to see if it’s still doing it? If it is, please reply with a screen recording of this! :slight_smile:

Hey @Chelsea_Ring please see attached a screen recording of what happens everytime I try and go into timeline view of a device. Please note that this is after I uninstalled the app, rebooted my phone, and then reinstalled it as per your instructions. It did not help the problem. I tried uploading the mp4 file of the recording but apparently this discusstion board does not allow that type of file so I had to zip it. If you can’t open it please let me know and I will email it to you.


@AHR Sorry for the delay in getting back to you! I have had this matter officially escalated up to the appropriate teams. I will make sure to keep you posted in this matter as we learn more as to why this is happening on the Timeline view for you and what we can do to improve it for the future. Thank you neighbor! :slight_smile: