Error P1-99 Doorbell Pro can’t connect to WiFi anymore

P1-99 error doorbell pro just drops from WiFi, with no changes to network, all other ring cameras working, WiFi working, tried connecting the doorbell to the chime network and it worked again. This means you need to purchase and set up a chime doorbell to get your doorbell pro working again or spend hours with customer support trying to get the doorbell pro to connect to wifi again, which it will likely not from the sounds of a closed discussion on this matter that was never resolved/solved.


Having the exact same issue. Doorbell and spotlight cam fell of the network suddenly last night. Spotlight cam can’t find the network it was previously connected to (not even showing in list) but I’ve managed to connect it to a backup network. Doorbell, however, is kaput. Won’t enter setup mode, changed the battery to ensure its fully charged, infrared lights seem to suggest it monitoring movement but zero connectivity. Error code P1-99 and not a stitch of info about it online. Will call the tomorrow.

Having the same issue. So guess I’ll need to call to have any hope of resolving.

Code P1-99. Same as above. Spotlight stopped working last night and doorbell camera today. WiFi not changed. Working great. Doorbell and spotlights error P1-99. Have reset power…messed on the app. Can’t get anything to work. HELP? I’m gonna be so ■■■■■■ if these only lasted 16 months….

Hi neighbors. The P1-99 code means that your device is not able to find a reliable internet source. You may need to bring your device closer to your router or WiFi extender for setup.

1 Like

Also just got this code, only bought it in May and found it pretty useless, bad video at night batteries only last 3 weeks and take a day to charge from what is said above the error can’t be fixed will send it back under warranty one of the most expensive and worst mistakes I have made will get a door bell that you don’t need to pay to monitor going forward as well this is just a waste of money - the Tom Ring comment is a joke as it works fine and without moving the router it suddenly drops off…

1 Like

Hi @user70966. Thats the thing about WiFi and connection strength, if there is a weak connection, it can drop off without notice or a seemingly obvious explanation. What is the RSSI for your device? Is it connected to a 2.4GHz or 5GHz network? What WiFi channel is your device connected to? These are all things that factor in to a P1-99 error code.

I’ve got the same issue. Moved the Chime (1st gen) around through several different power outlets, to no avail. The light does go on but it won’t flash after pressing the reset button for 5, 15 of even 30 seconds. I removed it from “my devices” but now I can’t re-add it, as it won’t connect to my Wi-Fi.
The Chime is currently plugged into an outlet right beside the router, so connection shouldn’t be an issue. Other devices don’t have connection problems no matter where they are in the house.
It seems to me the Chime has / causes the issue. Hopefully there’s a solution.

1 Like

I’m having the same issue only the chime (1st generation)is not working. I’ve tried several different methods none of them are working. And checked it is outdated and warranty is expired as well so what do you do when all options have failed?

My Ring Pro (hardwired) was working this afternoon but this evening it showed offline on the dashboard. WiFi is working for all other connected devices in the home. The doorbell was displaying a solid white ring. I tried to reconnect it to the Chime Pro (which is connected to WiFi). The reset button made no effect on the lighted ring on the doorbell I got a P1-99 error code when trying to reconnect it. I came back to it later to try again, and found the doorbell flashing blue-the whole ring. Like 4 times fast then a pause. Once again the reset button has no effect. The Chime Pro says it cannot find it.

1 Like

Same. My ring has been working fine all day. Now all of a sudden says offline. I tied restarting but got nothing. Frustrating !

1 Like

Update-just checked the doorbell again. Blue light still blinking. Pressed reset button several times with no change. Pressed and held until blinking stopped- about 10 seconds? No light showing then white light started blinking. Restarted process to connect to Chime Pro. Reconnect was successful. Working fine now.


That’s great news, happy for you!

1 Like

Update: I called Ring Technical Support yesterday and after going over all steps the lady concluded that indeed my Ring Chime is broken. The warranty had already ran out, but she offered me a discount to order a new Chime.

I hope everyone else’s issues will get sorted out soon too. Best of luck and happy holidays! :santa:


Hey neighbors, thanks for sharing your solutions and troubleshooting steps in this thread. Wifi connectivity issues can have various different causes, and solutions are often not a one-size-fits-all situation. Here are a few general things you can check regarding wifi connectivity:

  • Some Ring devices are compatible with 5GHz networks, but most are only compatible with 2.4GHz. Try separating your wifi bands if your router is dual-band, or create a guest network using only the 2.4GHz network.
  • Check the signal strength for your Ring device by looking at the RSSI number on the Device Health page. A weak signal can affect connectivity.
  • Turn off mobile data on your phone, then run a speed test at the installation location of your Ring device. This will tell you if your Ring device is receiving adequate download and upload speeds.
  • Make sure the ports and protocols used by Ring devices are open on your network, and check the wifi channel.

If you’re still experiencing connectivity concerns with your Ring device after reviewing the information above, it would be best to reach out to our support team for further troubleshooting assistance. They can take a closer look at things on the back-end.

Hi, My Chime Pro can not connect to my wifi. I tried to put it together with my router, and nothing; I used an extender, and nothing moved around different outlets and nothing. I think is not working/bad. Does it have a warranty ??? and I got this P1-99

I’ve been having issues for about two weeks with my new WiFi 6 router. Even though it’s connected to 2.4GHZ it will not stay online. Can’t view lives and missing tons of notifications. It’s sensing motion but not capturing video at all. Stinks because the WiFi 6 has been a great improvement but not compatible with the ring.

I think the recent cold weather has depleted battery strength. Device health said 67% but when I plugged USB in to charge it went to 1%. I then asked to connect to a different wifi network picked the already saved one from the list and it connected ok

I have the same for some reason every couple of days now has been perfectly ok we have the ring Wi-Fi extender does not make any difference if I power down the Wi-Fi at this point reconnects Ring system needs a re fresh capability please otherwise how do you operate when on holiday as this is the main point how having the system
We have eight camera and alarm so a refresh is a must surely

My ring peephole doorbell was having this same issue and I spoke to a tech for nearly an hour and a half. She had me install the update to my iPhone, reset the ring camera, reset WiFi and no luck. Finally she stated that it was my device and that it was no longer under warranty. I remembered I had an extra wire that came with the ring. The piece is like a flexible wire that connects the inside piece of the doorbell to the outside. I changed the old one out and replaced it with the new wire and wahlah! Live view working and no connection issues. Idk what happened but it worked!!!

1 Like