Erratic charging of ring doorbell

I have an older ring doorbell. It is hardwired and previously worked to charge. The old standard chime inside had to to disconnected, after which the charging stopped working. We had an electrician look at it, and when he left it was charging… but it has stopped charging.

Appreciate thoughts on both issues, including if the issue could be it’s just so old it stopped charging.

Thank you,

Sean

Hi @ableman42. If your Doorbell is not trickle charging and you had an electrician already look into the wiring, you can try the following steps:

  1. Fully charge your Doorbell battery.

  2. Factory reset your Doorbell by pressing and holding the setup button for 20–25 seconds.

  3. Reconnect your Doorbell to your wifi network and remount it.

If you have tried this step and are still having the same concern, give our support team a call at one of the numbers available here for further assistance. If you are outside of the US, please visit here to see how to contact support.