Entry delay not working - Alarm Sounding

I’ve got my Entry Delay isn’t working. I’ve got it set to 120 seconds and when it’s set to Away and armed as soon as there is any motion the alarm goes off. This means when I walk in the door the alarm goes off and I don’t have time to dissarm.

Have you verified that you have the Placement defined in the settings for your door to be Main Door?
Have you tried removing your motion sensor that is setting of your alarm, then adding it back?

1 Like

This is because motion sensors trigger the alarm immediately regardless of the entry delay. Never place a motion detector in proximity of your main door.

I just looked and it appears you can set your motion detector to “entryway” under "placement (in device settings). This should give you a delay but I’ve never had good experiences with motion detectors covering primary doors.

Hi @user14760. Make sure the Contact Sensor that you’re triggering when you walk in the door is set to Main Door in the placement settings so it receives the Entry Delay you’ve set. If you have a Motion Detector near the door, make sure it is set to Entryway, otherwise it will not receive the Entry Delay.

You can change the placement for your Sensors in the Ring app by doing the following:

  • Tap the Menu in the top left.
  • Tap Devices.
  • If you have Doorbells or Cameras, tap the Alarm Base Station to bring up a list of your Alarm Devices.
  • Tap on the Contact Sensor or Motion Detector you wish to edit.
  • Tap on Device Settings.
  • Choose Placement under General Settings and change this to Main Door on a Contact Sensor or Entryway on a Motion Detector and save your changes.

I hope this information helps! :slight_smile: