End of Beta Test Help


I recently finished Beta testing a Doorbell pro for project Aurelia and everything was working fine with the Beta App. Once the Beta app expired I deleted the app and installed the latest app from the app store. With the app from app store (5.33.0) I can no longer see my doorbell in the App or add it as a new device using setup. I still get push notifications for motion and bell presses and integrration is stll working fine with Alexa but i just can view the camera in the app and it doesnt show under my devices in the app but does on the website.

I tried to log issue with project support ticket but link to centracode just says page unaviable. I called support but they were not able to help me.

Hi @PVL. Please remember not to discuss anything beta related outside of the project page on explorer.centercode.com. If you submit a report in the project you are participating in, the team can respond to you there in order to help you get this sorted out. You can also contact our support team directly at one of the numbers available here. This is a neighbor-to-neighbor support forum, so we’re not able to look into your account to see what may be going on, so following up on the project page or with our support team is the best solution. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support

Hi Caitlyn

Thanks for the reply and I understand you are not able to view my account. I am really trying not to discuss anything related to any beta test.

As mentioned in the original topic I am no longer able to view the project in http://explorer.centercode.com/ as it is no longer showing and no way for me to reach the project owner or raise support requests

I spent over an hour on the phone with support and they were also not able to help me or solve my problem.

Do you have any other way for me to get support or contact the project owners as all the emails related as noreply emails



I am experiencing the same issue. I tried clicking on the ring app. It said, beta expired. I deleted it, reinstalled “production” app and not I cant use the doorbell at all.

Hey neighbors! I double-checked with my team on this for some more information, and they did confirm for me that you’re supposed to return the beta test device after the testing is over. You should have received a return label with the device. If you did not receive one or you no longer have the return label, you can reach out to the appropriate team via email at ring@beta.ring.com for more information. I hope that helps! :slight_smile: