Doorbell Won’t Connect to WiFi Anymore

My Ring Doorbell 3 device has been working for months without any issues until 2 days ago. Now it won’t connect to my Wi-Fi. It sees my network but the app just spins when attempting to reconnect. No changes to my home network have occurred and no Wi-Fi updates have been applied. Restarting the Wi-Fi doesn’t help. The battery for the doorbell is at 97% and my router is literally 10 feet away from the doorbell. What could have happened?


Our doorbell is saying Offline. It still records but can’t view live or when someone rings it or sets the motion off.
Is that the problem you are having also? It just started today.

Hi neighbors! Try setting the Doorbell back up in the Ring App using a different smartphone or tablet if you have one available. If you’re not able to complete a new setup to reconnect the Doorbell to wifi, you can find more troubleshooting steps in our Help Center Article here. If this concern still persists, try fully resetting the Doorbell by holding down the setup button for at least 20 seconds. After the reset is complete, attempt the setup process again to reconnect your Doorbell. I hope these suggestions help. :slight_smile:

My ring hardwired doorbell stopped working properly about a week ago. I have tried resetting my doorbell several times. It keeps saying it is offline through the App but the doorbell works sometimes, it had worked with no issues for months before this. Was there a firmware update that is causing issues?