Doorbell will not connect to new WiFi network

Hi,

I’ve recently moved WiFi providers and my Ring Doorbell will not connect. I go through the process but it will not pick up any networks at all, if I try and add mine as a ‘hidden network’ it gets to 95% then hangs there. Occasionally it asks what lights are showing (right white light is flashing) but then if you choose that on the menu, it simply goes back to the beginning. Any ideas? The doorbell is currently useless!

Anyone? Any advice please?

Hi,
Not absolutely sure but make sure your router security settings are WPA-2, NOT WPA-3. Ring devices won’t work with WPA-3.

I’m having the same issue. I have a new Arris G36 modem/router. Set the 2.4ghz network for WPA2. Neither my chime pro (1st gen) or doorbell (2nd gen) discovers any networks when it gets to that point in the set procedure.

Thank you, I’ll take a look

Mine see no networks at all too, very frustrating

I tried with a family member’s phone who has a newer phone (mine was new in 2019) and he could see the networks and brought it back online. Very annoying that nothing worked for me though.

Hi @user70593. I’m glad to hear that using a different device during the setup process worked for you! This is a common troubleshooting step we recommend if the setup is failing.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.