Doorbell Stuck In Loop

Hi - I have several ring devices - two outdoor cameras, one indoor camera and two Chime Pro’s all working fine. However my battery Doorbell has stopped working suddenly. Came home to find the blue light flashing and no connectivity.

I’ve tried resetting (both short and long presses), changing battery and moving wi-fi networks and its still broken. Basically it goes into set up mode (white spinning light) but can never find the chime pro or home wi-fi network. I’ve also tried removing it entirely and setting up from scratch but I still get stuck as it cannot connect to anything. Today when putting the battery in the app states its updating but 2 hours later and its still in the same state…

Any ideas how to break the loop? Or is it properly broken?

Thanks. Rich

1 Like

A post was merged into an existing topic: Network Connection Issue

Hi @Richie180480. Typically a firmware update should only take about 15 minutes or so. Holding down the setup button for 20 seconds will perform a factory reset, which I would recommend doing so if you haven’t already. If your router is dual-band, with both 2.4GHz and 5GHz, try separating the bands and create a guest network using only the 2.4GHz to connect the Doorbell to. Lastly, verify that the ports and protocols used by Ring devices are open on your router.

Should you still be unable to update your Doorbell, or connect it to your wifi network, please give our support team a call at one of the numbers available here for further assistance. If you are outside of the US, please visit here to see how to contact support.

Hi - thanks for the response. Factory reset just takes me back to the start of the loop - flashes white for a 10-15 seconds and then flashes blue and won’t connect to anything. I’ve done this several times but the furthest I have got is an audio message saying “updating” followed by flashing white light but hours later and its still doing the same thing. Doorbell worked perfectly fine for the last 5 years and have made no changes to wi-fi so don’t think that can be the issue. (Bearing in mind its not even getting to the point where I need to input a password for it to join a network)

@Richie180480 I mentioned some troubleshooting steps regarding the wifi network, as issues with the network could impact the Doorbell’s ability to complete an update. However, since the Doorbell is not going into setup mode despite all troubleshooting attempts, you’ll need to follow up with our support team to determine the best option moving forward.