Doorbell quit connecting

I have a 1st Gen for several years and simply quit working. Doesn’t ring or connect to home network Removed it and charged it for about 18 hours. Now just has a blue light on front and won’t connect to my Google Mesh network. Everything else in home is connected to network and working fine. Checked password for network and it is correct. Tried a complete reboot (several times) and it simply is not connecting to iPhone (12) or network which has way more coverage than to our home. It has worked fine up until about two weeks ago. Now sitting plugged in with orange USB cord on my desk but isn’t doing anything else except glowing white. It has gone to white light spinning or lit up on left side a couple of times but not connecting to network. Have now reattached to placement by front door and it will ring although not on iPhone - if I was standing near front door I might hear it. Suggestions. Maybe it just died after several years of placement? It was “blue” one front after I figured it was fully charged.

Hi @4cf995946f2efdbe9d663564ca6bb9. Thanks for sharing what troubleshooting steps you have already tried. When performing a reset, ensure that you’re holding down the setup button for at least 20 seconds, and then set the Doorbell back up in the Ring App. You can follow the steps under the Set Up a Device tab to take the Doorbell through a new setup. If it’s still not connecting to your wifi, try performing the set up on a different smartphone or tablet if you have one available, and ensure that your wifi password contains only alphanumeric characters and not special characters. Let me know if any of these suggestions help. :slight_smile: