doorbell pro will not enter setup mode

After 6 months of perfect operation, my ring pro lost connection with wifi. I have tried the hard reset. After holding for 2o seconds, it sits dark for several seconds and then the circle starts pulsating. It does this for several minutes. When it stops, I push and release the orange button and nothing happens. I never get the spinning white circle. I have done this numerous times. Suggestions?

Hey @calcteach1. Since you have done the extend of troubleshooting on your end, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

Thanks, Chelsea. I will call tomorrow.

1 Like

what was the outcome? I’m having the exact same problem

I had to call customer service and let them walk me through everything i had already done about six times. The guy decided i needed a replacement. They sent me a new one. It took about seven days.


Similar problem too me.

Had my new Doorbell Pro working for less than two hours when I noticed that it was ‘offline’.

Hit the small orange button but it wouldn’t go into ‘Setup Mode’. After numerous attempts and a couple of hard reset (hold small orange button in for 30 seconds) and reviewing comments here and elsewhere on the web, I decided my power supply was at fault, so ordered the Ring Transformer.

Ring Transformer has arrived, disconnected Pro from outside the house and then tried repeatedly to get the ‘Setup Mode’ to start.

After a hard reset, the device has a slowing pulsing white light. Left it plugged into the Ring Transformer all night with this solid white light.

If I press the big button on the front for a couple of seconds, the light will change to a blue circling light and make the ring-dong noise and then have a low solid white light.

How hard does the small orange button need to be pressed for?