Doorbell Pro stopped working after about 3-4 days

Short version first: I’m a computer network engineer with a lot of experience in wireless - so unless there’s some super secret-squirrel way of resetting this thing, I’m pretty sure the network chip (at least) has died. The Ring’s MAC address never shows up on my network, and the setup SSID is not visible to any device.

Long version - got the device through Woot/Amazon. Installed it with no problem, used the resistor module in my chime box, everything worked perfectly. Ring app reports last known power “good”, last wifi strength was -63. No problems there.

Now I get a solid white ring. When I click the setup button I get the circling blue ring and “Ring doorbell is in setup mode”. Try to connect with the app 10 times and it never connects. Don’t see the Ring in my wifi networks list (Yes, I know it could be non-broadcast, but that’s pointless). Never connects. Hit button again and it goes out of setup mode and eventually says it can’t reach the internet (left white LED). The ring has not joined my wifi (which hasn’t changed) and its MAC address is not showing up as a client, or rogue, or anything else - completely invisible.

I have held the setup button for 30 seconds until the LEDs go out. Doesn’t change any of the above behaviors.


Hey @teejwi. Thank you so much for taking the time to detail your findings and how the device has been not functioning despite your troubleshooting. Especially since you have done a full reset and to no avail to get the device connected again, this would be best to follow up with our support team on. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. I would love to hear what else they’re able to do for you, so please feel free to come back and let us know how this goes! :slight_smile:

I have exactly the same problem. I even recycled the power, which did result in getting my DB back to set up eventually, but once there it cannot find the Ring-MAC network. I have been seeking some assistance or advice for 3 days - to luck. I am about ready to return it.

I have the same problem. Bough the Ring Doorbell Pro 3 a few days ago. Everything was working fine until yesterday evening. We had a windstorm here and lost power 4 times within 5 minutes. Since then I haven’t been able to get the doorbell to reset. I’ve tried everything suggested, but no dice. Still doesn’t work. Anyone know how to fix this?

Ever get a fix for this? mine started doing this a week ago.

I ended up returning it to Amazon and getting a new one.