Doorbell Pro Stopped Connecting, Cannot find it in setup mode to reprogram

We have had the Ring Pro hardwired to our doorbell’s power for a couple years. Last week it stopped connecting, we followed the app’s troubleshooting steps and then a few other tricks.

  1. Rebooted wifi routers (LinkSys hardwired Velop, rebooting all nodes).
  2. Attempted to Enter Setup on Ring and then exit with button
  3. Restarted Ring by removing power, waiting 10 minutes, powering back on
  4. Attempted to enter Setup on Ring (doorbell enters setup mode, but neither of our phones can see the Ring’s wifi to connect to it.

After #4, I started using my NetSpot app on the laptop - I cannot find it’s setup hotspot. We tried hard booting a few more times with long power outages, still that little wifi chip doesn’t seem to fire.

Anything else to try before we buy a new doorbell (It’s over a year old, so probably no warranty)? Doorbell Pro Stopped Connecting, Cannot find it in setup mode to reprogram

Hi @Miko5. It sounds like you’ve done all of the typical troubleshooting that I would recommend. It would be best to follow up with our support team to see the next best steps to get you up and running. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.