Doorbell Pro offline and can't reconnect

Two or three days ago my Ring Doorbell Pro went offline. The Ring came with my new Lennar home which I closed on 13 months ago. The Ring has worked fine up until this point. Nothing has changed on my home network and my other Ring devices are all working fine still. I rebooted my router, no difference. I tried reconnecting the Ring to my wifi, no change. I did a Factory Reset on the Ring and still could not get the Ring to connect.

The weird thing is that when trying to connect the Ring app tells me to look for the SSID Ring-344c4f but it never appears; however there is an SSID of Ring-344c4b with maximum signal strength (obviously connecting my iPhone to that network doesn’t allowed the Ring to connect successfully). Any ideas? It’s almost like my Doorbell Pro has changed its SSID, but surely that’s not possible?

Hi @colinblake. Let’s try a few things. First, completely remove the Ring Pro from power for about 10 minutes. While you are waiting, go into your iPhone settings and turn off WiFi Assist ( found in the Cellular menu, all the way at the bottom). Next, power the Ring Pro and wait for the start up sequence. Then in your Ring app, attempt a new setup. Follow the on screen prompts to reconnect this device. Let me know if this helps!

Hi @Tom_Ring, thanks for the suggestion. I’m away for a few days but will certainly try this when I’m home again.

1 Like


Finally got home and was able to experiment. Removed power for 30 minutes, reconnected and went through the setup. Same problem. After scanning the QR code the app says “Ring wants to join network Ring-344c4f”. But shortly after it says “Unable to join network Ring-344c4f”. And if I check which networks are available I see Ring-344c4b. Notice the last letter is different.

So I started again and this time said I didn’t have a QR code. After answering all the questions I get “Do you want to join Ring-344c4b”. Looks good! I say yes, it asks me to select the WiFi and enter the password, and I get the “Rome wasn’t built in a day message”, the ring goes from white to blue, and the progress meter gets to almost 100 but then it fails (cannot connect to the internet).

Finally I tried completely removing the device from my ring app (in case that was interfering with the setup) and went through the above steps again but got the same result.

So I’m stuck and need help.

I ended up calling Ring support and after 30 minutes of troubleshooting they confirmed that the doorbell had gone bad and needed to be replaced.

1 Like

Hi @colinblake, thanks for sharing an update on this. I’m glad our support team was able to provide a solution.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.