Doorbell pro keeps trying to update software then loose connection

set up doorbell pro and it works OK then it says updating internal software and then goes offline. The WiFi connection of the doorbell shows in the WiFi list and you have to setup again. When you restart it it starts to update firmware again and so on and so on

1 Like

Hi @Sparker26. Have you tried performing a full reset on your Doorbell? You can reset it by holding down the setup button for at least 20 seconds. After this, you may want to try a fresh setup in the Ring App by following the steps under Set Up a Device. This should prompt any applicable firmware updates to complete. Let me know how that works for you! :slight_smile:

1 Like

have been in touch with customer support and they are going to replace it. Hopefully that will solve problem

1 Like

Hi, I’m having the same issue, did you manage to resolve it? What was the fix?

I am having exact same issue with my ring doorbell pro. Everything seems to work until the dreaded firmware update kicks in and when that finishes installing my device goes offline. Done hard reset about 15 times now. I’m going round in circles. It must be a dodgy device I have :frowning:

Has any one had any luck getting their device to work or did you receive a new replacement device from ring and if so did that work?

I’ve had a 1st generation ring doorbell for the last 4 years and that’s worked fine so I no there is no WiFi issue. I got the ring doorbell pro as a present from my brother so am gutted I’ve gone to have it installed today along with the ring transformer that my electrician installed and after all that the ring doorbell pro is not working when I go through the setup process.

Did you get replacement device sent out and did it work? I’m sure my device is faulty as WiFi and power is absolutely fine.

I am having exactly the same problem. Any solutions?

Checked with BT and they have confirmed it is connecting.

Exactly the same issue!!
It’s infuriating, going around in circles.
Considering the usual setup of ring devices is so simple, telling people my doorbell doesn’t work is so embarrassing! :triumph:

Does anyone have a solution yet?

1 Like

Hi Everyone.

So update… my doorbell pro camera fingers cross is working as it should do now.

I spoke with the ring team and explained everything and they agreed I had done all the correct trouble shooting. They wanted me to speak with the advance technical team who would be able to look into the issue further.

The advance technical team logged into my account on their system and disabled the automatic firmware update and got me to reconnect my ring doorbell pro through the app which I have done and it’s now working correctly and not going offline as it’s not trying to install a firmware update after setup.

So my advice is call the ring doorbell team and ask to speak with the technical team and explain that you need them to disable the automatic firmware update as it makes your doorbell go offline during the initial setup process.

Need help same issue. Reset the device multiple times. Each time it connect and then disconnect and won’t reconnect again

Hi there, @MattR6! The speed and efficiency of the initial update following setup will depend on the wifi signal strength. This signal strength can be confirmed in your Ring app as RSSI. During setup, try selecting the 2.4 Ghz network, instead of the 5 Ghz connection, for best connection over distance and through exterior walls.

If this concern persists, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

I have the same issue. I have ring doorbell pro. It did connect for a few hours after I waited over 24 hours. But then disconnected again. Ring reported that my ring doorbell software was updated. But I guess after you do a reinstall the ring doorbell automatically tries to do a software upgrade, even if you have the lastest software version. My wifi is fine since all of my other devices work fine. My ring doorbell is out of warranty. So I might try a different smart doorbell if this doesn’t get fixed. I have tried to reconnect my ring doorbell a dozen times but just keep going in this loop where it states it updated, but does not connect to my wifi.