Doorbell Pro keeps losing connection

A few weeks ago I purchased a Ring Pro, and had it installed by an electrician. Whenever I connect it through the App, it states it is updating it’s internal software. Before this is completed however, it loses its connection altogether.

I then, on advice from Ring, bought a Ring Chime Pro, and installed this about 40cm away from my doorbell. However when trying to connect the doorbell to the Chime, the same thing happens.

When looking at the app, it is saying it gets 39930 mV, and the WiFi gets an RSSI of 64.

The Chime Pro and normal Chime have no issues connecting to the internet.

I double-checked the internet settings, it is only broadcasting on 2.4 gh, Channel 1. Password doesn’t contain any special characters or anything.

Anyone else have similar issues, and if so, how did you resolve them?

Hi @Gerben. A few things you can try. First, remove the Ring Pro from power for 3 minutes, then reconnect. Allow 2 minutes for the Doorbell to boot up. Next, press and hold the setup button for 20 seconds, then allow for 1 minute for the device to reset. Then, try setting up the Ring Pro again. This is a good trick to get the Ring Pro to connect. You can also try placing your Chime Pro at a halfway point between your Ring Pro and your router for best result. I hope this helps!

Hi Tom,

I tried to do this twice, once with connecting it to my Chime Pro and once to my wifi, but it still loses connection after a minute.

The weird thing is, when I look at the firmware it is saying it is up to date, but as soon as I reconnect it, it is saying it is trying to update the firmware, which can take up to 15 minutes

Tom,

What if you are 2,000 miles from the doorbell (which I am)? Doorbell seems to be working correctly, but when I try to look at a Live View, all I have had today are Black Screens! It worked fine yesterday and the year before (Since I installed it in fact). Is there anyway for me to fix this from 2,000 miles away? When I am away from home like this for an extended time is when I need this to work, all of the time! This is why I purchased it, for reliable monitoring of my my front door when I am out of town for long periods of time!

Thank you!

Hi Tom,

I have an identical issue.

The installation runs fine, the connection is OK for about 10-15 mintues.

Then suddenly without any change it gets disconnected and there is no way to get it back on then to push the side button and do the installation process again.

The RSSI I’m receiving is -68 and speed check next to the doorbell is delivering excellent number (164 Mbps down and 96Mbps up).

It is driving me really crazy… Installing a doorbell via WIFI is easy with ring they said.

The suggested solution is not working for me and I’m looking for a good resolution.

Hi @jornvdd. There are a few things that can contribute to an intermittent connection. Those things being power and wifi connection. First, you’ll want to make sure that your transformer is at least 16 VAC and 10 VA. You’ll also want to make sure your Pro Power Kit is installed on your chime kit and you’re wires are either 18 or 16 gauge wires. Lastly, make sure you have the correct Chime Kit selected in the Ring app under your Ring Pros device settings.

A RSSI of -68 is on the weaker side of connections. I would recommend rebooting your internet router to see if that improves the signal. If not, you may need a Chime Pro to extend your wifi signal.

If you’ve checked both those items and you’re still having this concern, I would reach out to our support team. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.