Doorbell not connecting

Hi, we have a ring pro with chime combo. We are running google wifi. We were able to connect for a period of a dsy or two, but something happened and the doorbell was disconnected. Since then, we have tried countless times to reconnect with no luck. Currently the doorbell will not enter setup mode. We have tried hard reset and disxonnecting and reconnecting with no luck.
Can you please help.

Hey @TnM. If you Doorbell Pro will not enter setup mode and the reset is not helping power it back up and turn on, there may be a concern with the power to the Pro. Please check out our Ring Help Center Article here to ensure it is not a power concern. In the event the device may still not boot up, you will need to reach out to our support team via phone here. Let us know how this goes!

Hey Chelsea,
Thanks for the response. The doorbell is connected woth the ring supplied adaptor plugged into a powerpoint. We’ve double checked this powerpoint and had our electrician check the power supply to the unit and there are no issues there. Given this didnt fix the issue, any other possibilities?

Hey @TnM! Thank you for checking those power variables. As long as your device is powering up and entering setup mode, it should complete a setup. Depending on what step of the setup it is failing at, sometimes trying another mobile device just for the initial setup can help.

If your Video Doorbell Pro is not powering up, or responding with LED indicators, despite power being sufficient, please reach out to our support team for more in-depth troubleshooting. Feel free to let us know how this goes! :slight_smile: