Doorbell not charging, just Flashing full blue

I saw another related thread but it did not solve my issue.

I have a Ring doorbell generation 2. I have set it up to operate off battery and charge it every so often. Upon putting it on the charger from 13% battery, the entire blue light rapidly flashes. I re-seated the cable, tried various mini-usb cables including the included original orange cable, and various charging bases. All gave the same result. I left the device on the charger with the rapidly flashing blue light for approximately 6 hours. Upon removing it from the charger, i pressed the ring button and also allowed it to capture motion. The device still reports battery life at 13%

Hey @Jayroley. If your device is not holding its charge, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

1 Like

I am having the same issue but my doorbell did charge but after just keep fashing blue :frowning:

I’ve just had the same issue when I used a Samsung USB plug. I switched to my iPhone plug and now it’s charging properly.

I found same issue, I found that if you let the unit get to room temperature then put it on charge it starts charging suggesting that the battery won’t accept a charge when it is cold.