Doorbell doesn't ring and remains offline, immediately after successful setup

I went through the setup process and everything worked perfectly fine. Got a location and name set up, got the wifi set up and it connected with no problems. The blue light flashed after the setup finished, so it connected to wifi, and it says setup successful.

But after this, the device is basically just a brick. Am I supposed to do anything after setup but before actually using it, in order to make it work? Right now, when I press the doorbell button, it doesn’t ring. Nothing happens at all. In the ring app, the device shows as offline (even though the setup just finished and it had no problems connecting to the wifi network). If I press the orange button twice to get it to reconnect, the light goes blue for 5-10 seconds and then it goes off again, and nothing has changed.

I have tried restarting the wifi network, and pressing and holding the orange button down, and redoing the setup many times, but nothing has changed. I checked on my router and it says it is connected and on the 2.4GHz band, but the app constantly shows it as offline.

Just because it has a connection doesn’t mean it is a strong connection.
Contact Support ( Contact Us – Ring Help) to work through some trouble shooting steps and they’ll be able to tell you what warranty/replacement options you have if they can’t get it working.

There are no problems with the wifi connection, it has no problems connecting during the setup even when it is far away from the router. I checked the router and it actually says the doorbell remains connected after the setup, and I also managed to get it so that it rings when I press the button now. But the app still says that it’s offline.