Doorbell Charge

Hi there,

I have a problem with my doorbell charging. I plug it into a micro USB port and charge. Within an hour, the blue circle on the front is fully illuminated indicating the bell is charged. However, when I take the USB cable out and mount the door bell on the back plate outside after re-connecting the doorbell to my WIFI, the app then indicates that the doorbell is not charged.

I have tried charging overnight for many hours but the same happens. I have tried (multiple times) a factory reset to ensure the bell is connecting to the app correctly but still the doorbell doesnt seem to function. I have paid into a protection plan but with the doorbell not functioning, this is a pointless subscription.

I am interested in upgrading to the peep hole doorbell but this is quite expensive so I would like to understand what is wrong with my current doorbell. Can you please help?



Hey @RichLangford. Since you’ve exhausted all the troubleshooting you can do on your end, the best bet from here is to reach out to our support team over the phone here. They can walk through any more troubleshooting that may need to be done, and clear up why your Doorbell isn’t holding a charge. If it is deemed you need a new device, they may be able to help you out with a possible exchange. Please note that this may not be an option if they get the device back up and running, or you may have to pay a difference/get a code for a new one. :slight_smile: