Doorbell and Cameras Cannot Connect To WiFi

I just upgraded my WiFi routers (to a set of Eeros, coincidentally owned by Amazon, like Ring). I set up the new network with the same SSID and password. All of my electronics had no problem making the move to the new network…except every one of my ring cameras. Even the Ring Base Station easily detected and joined. However, my Doorbell Pro and two security cameras are offline and nothing I’ve tried will get them to connect to the new network.

I have tried setting up the Wifi in the app automatically using the information from the previous network—no luck. I have tried manually adding the network’s SSID and security information—nothing. I have tried restarting the routers…several times. I have tried factory resetting the cameras and adding them as new devices—still won’t connect. I’ve tried modifying my SSID and password in case any special characters were confusing the cameras. Unfortunately, I can’t change the Wifi channel (1, 2, etc) or band (2.4/5 GHz), as Eero—in their obsession with simplicity—does not allow you to do that.

The same thing happens every time. I get through most of the setup process (put the camera into setup mode, connect to its temporary Wifi network using my iPhone, and tell it which network to connect to). However, once the camera tries to connect to my main network, it waits several seconds before telling me “setup did NOT complete. Your Wifi router may be too far from the device” (it isn’t—it’s five feet away and no other devices have trouble with the signal strength). It sounds like something in the network setup or Ring’s software is preventing it from seeing my Wifi network, regardless of how strong the signal is.

Does anyone have any advice or ideas to help solve this? Thanks!