Doorbell 3 Plus fails to connect to WiFi


I was using my Ring Doorbell 3 Plus for half a year without any issues. A couple of days ago, I changed the WiFi network to my new WiFi. First it worked as usual, but then it stopped working.
If I try to connect the Doorbell to my old WiFi network it doesn’t work. I tried 3 different WiFi networks but I can’t connect my Doorbell to any of them.

The new WiFi exists with 2 seperate SSIDs, one as 2.4 GHz net and 5 GHz net. It supports g/n and WPA3 with downgrade option to WPA2. The password consists partly of special characters, such as “!” and “.”.

As I already stated, I can not even connect it to my old WiFi anymore. I did not change any settings of my old WiFi network, so I really don’t know what else I can try.

What I tried to connect to the WiFi network:

  1. Remove battery pack + insert battery pack again (blue leds flashing)
  2. Press orange button until white leds are circling around the button
  3. In the app: scanning the QR code from the Ring package in order to connect to the Ring Doorbell
  4. Select WiFi network and enter password
  5. Try connecting… but fails with 2 white leds on the right side of the ring button.
  6. Try again with different network, again the same issue.

What can I do? What is wrong with my Ring Doorbell?

I solved the problem.

First remove the device from your Ring app.

Then remove the battery pack and press the little orange button. Then while pressing the orange button, put the battery pack back in and wait for about 30 seconds. Then press the orange button again for 30 seconds, just to make sure that your Doorbell is set to factory defaults.

After that, proceed to install the Doorbell as a new device.

This worked for me.

1 Like

Thank you so much for this suggestion! My Doorbell 3 Plus stopped yesterday at 3:28 AM and while it showed connected, my Google Nest Router said not connected. Tried many resets, new setup, even spoke to Technical Support, and we could not get it to work. It was not suggested to remove the device from the App. I just did it and it is now working!

1 Like