Doorbell 3 connects to sub-optimal access point

Hi,

My home Wifi consist of a Netgear router RBR50 and a satellite RBS50. Both broadcast the same SSID, and both on 2.4GHz and 5GHz. All my devices on the network are able to select the one with best signal conditions, even dynamically when moving around. But the Ring, which obviously is in the most difficult location as it is outside, has the strange tendency to connect to the worst network and then the app shows “very poor wifi signal”, RSSI -82. It connects to 5GHz, which is already weak at my front door, plus it connects to the AP that is 15 meters and 3 brick walls away rather than the one just on the other side of the front wall! Why the Ring doesn’t select the network with best signal? After I remove the battery and let it restart it connects to the closer AP, RSSI is -63 , then after a day or so it goes back to the AP with with weaker signal.

All my other devices work find and roam well through the house, so i am not inclined to setup different SSID for the 2.4 and 5GHz bands to overcome a bug in the Ring. It would be great if the app would allow me to select the right band and best AP.

Any suggestions?

Hi @Leenq. Unless the access point that you are trying to connect the Doorbell to has its own unique SSID and password, there is no way to force the Doorbell to connect to it. If it shares the same SSID and password as the other access points in your home, then you would need to adjust settings on your network or router to differentiate this. Once the closest access point has its own SSID to connect to, you can then manually connect the Doorbell to it under the Device Health page.

Hi, I think I know what is happening. When my Wifi networks reboots, the main router (far away from the Ring) comes online first, and the satellite (close to the Ring) comes online a few minutes later. The Ring latches to the first AP it sees, and even a stronger AP appears with the same SSID and password after a few minutes, the Ring doesn’t switch to the stronger AP. If I remove the battery and hardwired power from the Ring and restart it, then it catches the stronger AP. Could it be that the Ring doesn’t check for available APs from time to time to select the strongest signal? A reasonable workaround would be to have the possibility to reboot the Ring from the app, as it would avoid having to remove the battery and disconnect the circuit breaker of the hardwired mechanical chime.

@Leenq The Doorbell will not swap networks based on signal strength. Since the Doorbell’s setup button has to be pressed in order to put the Doorbell into setup mode, it cannot be rebooted remotely from the Ring App.