Doorbell 2ndGen HardWired but loosing battery


I have a 2nd Gen doorbell, used this battery-only at first because there was no way to hardwire it.

I recently moved to a new house and this house has a transistor/wired connection, making it easy for me to hook it up to my Ring Doorbell.
So, i took off the button of the old doorbell and used the wires to connect them on my Ring Doorbell.
In the settings it does say " wired ’ as a powersource so i was happy; no more changing batteries every 2, 3 weeks…

Now,… 3 weeks down the road i have seen the battery level going up gradually, like 1% each day, making me think this is more like a trickle-charging situation than rather a full-blown wired situation.

So… when i moved and placed my Ring Doorbell on the wall, my battery was around 20%… in the 3 weeks ive been monitoring i have seen the battery level go up towards 41%, but all of a sudden, in the last, lets say 7 days the battery went lower and is now 10%…while it is wired!!?..

Why does it at first (slowly slowly) charge, but now suddenly is heading towards a shut-down due to no battery?
Why is “wired” not making the battery go uo to 100% and stay there?

I did not change any setting, WIFI RSSI is -50, i do have all options on full/on max (120secs monitoring etc), which might drawn more power, but why did it charge slowly all the way up to 40’s and is now almost down to 0??

Anyone can explain what i do wrong?

for some reason i might expect a " you can charge it again the old way " answer as a solution, but i can already tell that this aint much of a solution. Unscrewing the Doorbell, then disconnecting it from the wired situation (after taking down the breakers to avoid electric shocks), then connecting it to an adapter, charging it upto 100, which takes half a day (no doorbell at that time), to connect it/wire it again while there is a wired-option…

hope there must be some explanation for this…

1 Like

You need to take a look at the doorbell transformer. The minimum rated power from a transformer is 16 volts 10vA and will not output enough volts or amps to completely maintain the battery in the doorbell. I recommend getting a larger transformer. The maximum rated transformer allowed is 24 volts 40vA. I would switch to this and you will see an improvement in your battery life. You might not even have to ever remove the battery and charge it again with the higher voltage and amps. Cold temperatures have this largest impact on how long the battery will stay charged. Hope this helps you

Thanks for the reply

I have 0 knowledge about these electronical things.
So, a 8V (10VA),12V (20VA), 24V (30VA) DIN rail transformer is too low?

It is weird though, woke up this morning and the battery went from 6 to 11%…it does charge, but it also drains. Temperature outside a bit cold, but way above freezing temps…

I just found out Ring also sells the adapters, specially for doorbells.

This would solve the issue as well… right?

24 volt 30vA transformer will work. The 30 vA is the watts (amps x voltage) that the transformer supplies to the doorbells. Its always better to have a lager transformer than too small.

WHat if i just get that Ring adapter as what ive shown in my other message… its a bit discounted as well as i am using the plan. WOuldnt it be easier to do it this way? Then no need to change the old transformator, placing a new one… or am i wrong?

Hi @Yaroon. Hardwiring a battery powered Doorbell provides it with a trickle charge, so the battery does not charge as quickly as when you manually plug it in with the charging cable. The battery may discharge faster than it can be charged via the wiring, depending on the activity levels. We have some information and troubleshooting steps here for unexpected battery drain. You can also use the Plug-In Adapter (2nd Generation) to plug your Doorbell (2nd Generation) in for continuous power.

I hope this helps answer your questions. If you’re having persistent power-related issues, it would be best to get in touch with our support team for further assistance. They can take a look at the device details on the back end and offer more in-depth troubleshooting steps.

I have the same problem. I bought a new doorbell because the “hardwired” stopped working for some odd reason. I have had an electrician out to measure the voltage and it is 24 volts as required. It worked for about 3 days and now is running on battery and below 70%. This is completely unacceptable.

Hi @terryr. Thank you for having your electrician verify the voltage on your wires. Twenty-four volts is definitely sufficient power to keep your battery trickle charging in your Doorbell. Try rebooting your Doorbell using the Ring app to see if it helps. If not, reach out to our support team for further assistance.

I am dealing with a similar issue. Doorbell was originally noted as hardwired in the app yet the battery recently drained to 1% and the app indicator switched to battery. As instructed, device was disconnected from my house and charged. The device drained to 1% again in less than 3 weeks. I had no issues until recently and of course the warranty has expired. Suggested solution was upgrade to new model. Spend $169 for a new and improved model.

I’m too believe a software/firmware update was launched by Ring that caused some sort of issue with the device. Device worked while under warranty now constant battery issues. I don’t have doorbell coverage for hours while charging.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.