Doorbell 2 does not recognise me as the owner

The battery must have died so after recharging it I tried to connect the doorbell back to the app, however it says that it must contact the owner to authorise me as the new owner…I have always been the owner! I haven’t received any email from them and just don’t know what to do. Has anyone experienced this before?

HI @Rolandrat! This definitely should not happen if you are the original owner. Please ensure you are logged in to the owner Ring account for the Ring app, and that your location is also showing properly in the app.

If you are able to see your Video Doorbell in the Ring app, you can access it’s device health section to reconnect it from there. As you mentioned, part of the Change of Ownership process is to receive an email for verification. If the above steps did not work, and ownership email is still not being received, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.