Device Transfer

I bought a refurbished camera from woot… I get an prompt that the device transfer and then I get an error that something went wrong

I tried all the recommendations, the instructions said to contact this group

Help me please!

Hi @user46799. If your Device Ownership Transfer is not completing because of an error saying something went wrong, try the following steps:

  • Verify your Ring app and smart phone are up to date with the latest updates available.

  • Disable any active VPNs on your phone.

  • Try completing the setup using a different phone or tablet using the same account you created on your phone.

If you have tried these steps and are still having the same concern, give our support team a call at one of the numbers available here for further assistance with device ownership transfers. If you are outside of the US, please visit here to see how to contact support.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.