Device says low battery but fully charged

I’ve searched community but no answers. Same questions but no answers. It’s been on charge for 24 hours and green light showing but still says 6% when reinserted.

2 Likes

I have the same problem. How you get support on these things without a phone call is beyond me.

I am about to return mine. They are not fit for purpose.

2 Likes

Hey neighbors! The battery percentage in your Ring app can sometimes take a moment to update. As long as you’ve charged your battery for several hours, it should be full. After reinserting the battery, test a live view to ensure the device automatically connected to the Internet. Once confirmed, your device health should reflect the new battery level. If not, try removing and reinstalling the Ring app on your mobile device. I hope this helps! :slight_smile:

2 Likes

Same issue. Battery fully charged. Still says low battery. Unable to view live. Still records motion and can be viewed in timeline.

Any fix for this issue?

3 Likes

you state that app may take a few hours to update the battery status, yet I have changed to a fully charged battery for 24 hours and yet it shows low battery. now I have removed the battery and my doorbell is actually offline, yet the app still show that my device is online and healthy. my recordings show a black screen.

what is going on here?

1 Like

After a couple of hours without battery while app showing my doorbell 2 as online and healthy, I decided to power up it up again. Slide in same battery earlier removed, let it connect, press button and now all seems well.

So, not sure exactly where the problem lies.

2 Likes

Hey neighbors! @Saiful Thanks for letting us know what you tried and how that worked for you. Typically if the Ring App is not showing the correct battery percentage after fully charging the battery, I’d recommend walking through a new setup of your device by following the steps under Set Up a Device. The battery percentage should automatically update, but in the instance that it doesn’t a new setup should take care of it! :slight_smile:

seems either the app or the server does not refresh frequent enough to indicate the actual status of the battery. again, when I got notification of low battery I replaced it with a fully charged one yesterday and until today it is still showing low percentage. do I have to carry out the ‘Set up new device’ each time I replace the battery?

@Saiful You shouldn’t have to, but if the battery percentage does not update even after triggering a test motion event, you’ll want to run through a new setup just to ensure the Ring is recognizing the fully-charged battery and can function properly.

your comment really not helping. you say I don’t have to ‘Set up new device’ each time I replace the battery but yet you say that it should help my device to recognise the new battery. earlier in one of the comments made by a moderator, he said that the app will take a moment to refresh the status yet mine have been replaced almost 48 hours ago and app still show low battery percentage. the doorbell is still recording motions and still works when someone presses the bell, but I can’t do any ‘Live View’ because it says low battery.

something is definitely not right somewhere and it seems I’m not the only one facing this issue.

6 Likes

@Saiful Typically a new setup is not required after fully charging the battery. However, in the instance that the Ring App is not registering that you’ve put in a fully charged battery, that’s when you perform the new setup as a troubleshooting step to resolve the concern. Since you have had this concern multiple times, I’d suggest reaching out to our support team at one of the numbers availablehere. They can look at your device more closely to ensure everything is working properly, and offer more advanced troubleshooting steps if needed. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19here to see how to contact support.

guess what?

I did as what you have recommended to do a ‘Set up new device’ and it still showing low battery. if the issue is with the battery, I’m sure the percentage would have dropped after more than 48 hours in the device but it is still showing the same percentage as when I changed batteries. the app also refreshes well because the WiFi signal strength vary each time I launch the app. only good thing now is that it is still recording motions and still notifies me if anyone presses the bell.

I tried calling support and it’s closed.

4 Likes

@Saiful If you’re located within the US, our support team is available from 5 AM-9 PM PDT, seven days a week. If you call within that time frame, you shouldn’t have any problems reaching a member of our support team about this concern.

I’m located in Singapore and I just called the support at 10am Singapore time (equivalent to 7pm PDT) and it says they’re closed. I’m beginning to lose confidence in RING and frankly I’m starting to source for other makes and will be terminating my subscription if this issue is not solved soon. thanks for responding to my posts.

1 Like

@Saiful Can you let me know which number you called? If you called one of the other numbers listed, the hours of operation may be different than our main number for the US, and I’d be happy to check this for you.

Same problem here! Charged both batteries for 24 hours and charger shows green light only. BUT when I plug the battery back into my VideoSpot Cam or Doorbell, the little light on unit shows red and the Ring App will not allow me to do anything because it says “battery is too low.” Then they take me to some useless tutorial which shows me how to charge the battery! I already know how to charge the battery!

3 Likes

Was this issue ever resolved? I fully charged two batteries the app still says “low battery” and directs me to a worthless video on how to change the batteries. I literally don’t see any way on the app to resolve the issue since the batteries are fully charged.

1 Like

If anyone is still seeking the answer… there is no direct answer to fix the low battery issue in the app.

I called into Support and the fix was to “setup new device” (for the affect device) which resolved the issue.

1 Like

Can’t see live view says low battery

Me too, that’s baloney.