Device Health not loading on iOS app

The device health is not loading for any devices in iOS. I have an iPhone 11 Pro Max running iOS 15.1.

Same here, started yesterday evening. Device Health won’t launch across 3 Android phones and 1 iPhone. Screen just spins then eventually times out displaying only the MAC address with no other information. I have 10 cameras (1 battery, 9 wired) which are all working and recording fine, but can’t display the Device Health from any of them.

1 Like

The Device Health screen should be loading as intended for you. I’ve tried this out on several Ring devices using IOS and each page loaded immediately. Please ensure there is not a VPN enabled on any of these devices, and try different connection types (Cellular data vs WiFI).

As it sounds like you neighbors have tried this, and even multiple mobile devices, this may require a closer look from our support team. Feel free to reach out if this concern is persisting for you! :slight_smile:

Please give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

Nope, no VPN, and nothing special. No network changes and everything else in the Ring app works fine. Videos are recording and working fine too. Tried accessing over 5g and same results. On my S21+ it will spin and timeout with a message stating “We’re having trouble getting to our system, please try again later.” On my iPhone and old S8 it just times out with no error.

Again, the Device Health populates fine on the Windows desktop app.

1 Like

Thanks for confirming those variables, @5150Joel! I’ll share this feedback with our teams here as well, as this definitely should not be happening.

Much appreciated, thank you @Marley_Ring !

No offense, but I’ve been with Ring for years now and can assess whether the issue is on my end or Ring’s end at this point. Sure, there’s been enough of times over the years the issue was on my end but this definitely seems like an issue on Ring.

1 Like

Has this resolved for anybody yet?

I have the same problem, plus my hardwired Ring Video Doorbell 4 no longer trickle charges. Nothing has changed wiring wise and this happened the same time the device status went awry.

No VPN on my side either, no network change, nothing at all. All I get is a loading icon for a few seconds and then it’s back to the device screen.

Just spent 30 mins on the phone with tech support and absolutely no help they want me to do all kinds of resets to my network even though this happens no matter what network I’m connected too and it works fine on my wifes phone on the same network

Any updates on this? I still can’t access Device Health from any of my cameras across 4 different devices from the Ring app. The fact that the Windows desktop app displays the statistics fine tells me the information is able to make it outside of my own network, from the camera to Ring’s servers.

My Android devices are on 3.46.0 and iPhone is on 5.46.0.

I’d suspect something changed on Ring’s end (or even Amazon Web Services) on 11-21-21 sometime after 5pm EST.

All my cams continue to work and record fine but the app will not display the Device Health. Identical to @Cortega01’s above screenshot, the Ring app just spins before timing out. My S21’s will show “We’re having trouble getting to our system, please try again later" while the iPhone and S8 time out with no error message.

image

Nothing has been resolved, I’m still unavailable to load device health on my iPhone and iPad. I contacted support twice, other than reset the network settings on the phone and reboot the router, they have offered no viable solution. Tech support says the problem is not at their end, but they have said that on other occasions, and it turned out not to be true.

Oddly this problem definitely isn’t widespread or more people would be reporting it. I’ve tried reinstalling the app on 1 of my 3 Android phones and my iPhone but it didn’t resolve anything. I too have rebooted my modem and router as well. No firewalls settings have been enabled or changed on my network either. Again, I’m very suspicious the problem may reside with Amazon Web Services (which Ring uses). This could also explain why everyone is not affected.

There’s just no way this is not a problem with the Ring app or their servers. Literally everything else works fine (including the Device Health of my Ring smart lighting).

I’ve not called into support, at least not yet. Last time I called it was for a problem with the Ring app, that affected every one of my cameras, that ended up being a problem on Ring’s side. I wasn’t wasting my time running a WiFi speed test from each of my cameras and resetting them to troubleshoot something that I knew for certain wasn’t a problem on my end. There are most definitely scenarios where it is our problem, or our WiFi, but this isn’t the case for this issue.

I too have talked to support twice and they finally realize it’s on there end because I’ve tried my log in on 2 different phones and wouldn’t work but my wife’s log in on the same phones worked fine but they gave me no time table for resolution as they seemed perplexed about the cause

1 Like

@user3405 that’s interesting and thanks for posting this. Who’s the owner on your account, you or your wife? My wife and I share the same ‘Owner’ account log in so all of my devices are all logged in with the same account.

Even more interesting being as I’m logged into the Windows desktop app with that same account and Device Health updates and works fine there.

I’m the owner on the account

@user3405 thank you again. I was just able to replicate your scenario and it worked for me as well. I created a new shared user account giving that account access to my cameras. Once logged in with that account, I’m now able to see the Device Health on all my cams but not if I use my Owner account.

Hopefully this is resolved soon since this seems to be account-specific.

1 Like

It always amazes me how large companies with such poor customer support survive. The people on the other end of the line likely have very little knowledge of how the systems actually work and use a flow chart to diagnose and attempt to resolve problems. If they invested just a little more in training and escalated tech issues in a more timely manner I believe it would add tremendous value to their product. Sorry for the rant, I know this adds nothing to helping resolve your issue.