Desktop app for Linux?

Is there any way to run the desktop app on Linux? I’d like to be able to check live view from my laptop like I can on my Mac.

4 Likes

Great question @LyndaN ! Currently we do not have an app out for linux platforms. Luckily, Linux is an open source operating system capable of a great many things. With it being so customizeable, maybe another neighbor using Linux has found an emulator that works with their system already and would be open to sharing their tips with you in this thread.

I’ve not directly spoken with any neighbors who have accomplished this, but would love to hear more if you decide to add it to your Linux system!

1 Like

Also very interested in seeing something that will allow people who like to use LInux be able to use a ring app. Fingers crossed.

5 Likes

+1 for Linux support

4 Likes

Also, can you make the Windows app available outside the Microsoft store? Us linux users can run it in an emulator if we can just get the installer.

5 Likes

+1

+1 for Linux
Would be nice to have this.

+1 for Linux Ubuntu. when can we have it!

Any chance we can get this sooner rather than later. I’m on Linux Mint and have no problems running most things from Windows as well thanks to Wine. A native install of the Ring app would be better but just getting our hands on a Windows installer would allow us to run on Linux.

A web interface would also be acceptable, failing that where is the .exe install ?

+1 for Linux app. The best case would be adding the Camera live view support to the web browser dashboard so that it works on any platform including Linux.

Another vote for this. Just getting the windows installer outside of the windows store would work.

I just tried the Ring app in the Microsoft store. It works great but I really really hate booting into Windows. Linux is “Home” and although my Windows install runs great, I soon miss Mint Mate, it’s terminal, and all the work and customization I’ve put into it.
So… +1 for a Linux app here too. :slight_smile:

It seems to be available on flathub, I tried “flatpak install flathub cx.ring.Ring” and it worked and I got the application installed. You have to connect it to your account, not tried that yet, but a step in the right direction. Not sure if this is very new or very old, as it is not visible in the flathub pages at Flathub—An app store and build service for Linux , if you search for Ring it’s not there, but there is a package.

It’s not there when you search flathub because it’s been archived. Sadly it’s not been updated in 4 years.
It would be nice for ring to produce a native linux app though.