Delete All Videos

On the Ring website there is an option to select all videos and delete them.

I can’t find the same option in the Android app - does this exist? If so, where?

If not, could you add a delete all feature in the app. We should have the right to easily delete all of our videos easily.

Also, when I delete a video does it actually delete it from Ring servers? or do you guys keep it and just not show it to me?

Good question @CrazyCat! There certainly is a way to delete all Camera/ Doorbell events on Android and through a browser. On the Android Ring app, please visit your Event History list. Once there, if you swipe right on the list of events, checkboxes should appear next to each event. There will also be an option to “Delete All” at the bottom right corner of the screen.

When doing this through the browser, please visit Ring.com/account in an updated browser window. There will be an option towards the top, or beginning, of the event list to “Select All” and then to “Delete All”.

Anything you delete is deleted immediately and in its entirety. I recommend downloading any important videos prior to deleting all, as a best practice. I hope this helps! :slight_smile:

1 Like

Thanks!
Just so you know on Android you have to long press on an event to get the UI to delete all, not right swipe.

Also it would be great if I could delete all of my alarm events too.

1 Like

I am on my Activity History page and all I have are drop downs to select All Devices or just the Doorbell camera I have (same result) or All Types. I do not have an option to select or mark all videos. There is a Delete and trash can icon to the right of the drop downs but it is barely visible and greyed out. Selecting the star next to a video does nothing for me. I am still on the new trial version in case that makes a difference but I too would like to trash my videos since most are from setup and testing anyway. I would like to clear the clutter.

Are you using an owner account or did some share permissions with you? Only owner can star and delete (unfortunately)

They really need a co-owner role.

1 Like

I bought the device and created the online account so I assume I would be the owner. I did grant access to my wifes email address but she only uses her phone for access. Maybe I’ll call Ring after the holiday to see if they can figure it out.

In my Ring app there is no checkbox to Delete All nor a swipe-right method to reveal individual checkboxes. You CAN reveal individual radio buttons by long-pressing an event. FYI, and IMHO, radio buttons aren’t the generally accepted GUI element for multiple selectkons. Check boxes are.

2 Likes

I finally called Ring support a few days ago. Per their support there is no way to do this on the web site. Maybe it will be there in the future since I do still see a faint light gray Delete button that doesn’t function. However in the Android app it does work but you have to use a certain series of screens to get there. Hitting the History button from the default page or Dashboard will not give you the option to delete events.

From the default page or Dashboard of the Ring app hit the three bars in the upper left and select in the drop down menu Devices. In my case I only have my doorbell so I select that one.

-In the next screen select Event History to present a list of Recent Activity.

-Slide one of the events to the right and you will see all of the events will now have a checkbox to the left side of the screen. Select the check boxes you want to delete and hit the trash can on the bottom left. I think you can also hit Delete All on the bottom right if you want to delete everything. You will get a confirmation dialog to confirm you want to delete them.

Once done all other people that have access to the Ring devices will also have those events removed from their list. I think only the owner of the account can delete events.

2 Likes

The website supports delete all too:

  • Go to the Activity History
  • Choose “Select All”
  • Click “Delete”

(Note: You cannot delete “starred” events with Delete All - if you only have starred events then Delete will stay disabled)

On Android you can delete all from the main history screen. Just long press on one video event, click the “…” in upper right corner of app and select “Delete All”. DO NOT select anything in the list view - just hit Delete All in the menu. This UI pattern is very atypical and not obvious at all, but it works.

As I read through these threads, I find very contradictory replies. It’s hard to seperate the wheat from the chaff. Can the Admins please clearly mark statements that are patently wrong?

Joe

Look at the first reply from Marley_Ring. They already stated you can delete from the browser and Android app.

This is NOT accurate and the problem is NOT solved IMHO!

On my Android Ring App, in the Event History, there is no swipe-right function, only a long-press function. This puts radio buttons next to each event. You have to mark each event you want to delete individually by pressing the corresponding radio bitton and then you can select the Delete function. There is no Delete All function anywhere on the page. A proper GUI would have check boxes next to each event as well as a Delete All checkbox at the top of the list which sets all the individual checkboxes. Pressing Delete would then delete any item in the list that is checked.

ALSO NOTE that in standard GUI practise, radio buttons are for mutually exclusive selections, not for group selections.

2 Likes

I kept asking the ‘owner’ how do I delete all the multiple ‘events’ most of which were during set up and yard work etc… etc… he said I dont know you have to figure it out with your phone. well I’m glad to have read your answer… that ‘shared’ accounts cannot delete… can we know why this is ? And if we cannot (example spouses) on ‘shared’ devices, if the owner deletes all the events will it then delete from my device ? this is not really good… my phone storage space will be used up quicker than I would prefer… obviously. please is there a way to fix this ? there’s only 2 devices connected… his and mine… and I dont want to have hundreds if not thousands of ‘events’ on my phone that I cannot delete after viewing… it’s very frustrating to say the least. please help.

they DO need co-owner! especially when the co-owner purchased the device because listed owner owns the house and wanted it… I should have the SAME authorities!!! this is not good… why is this such a difficult request!!! ?? what GOOD reason can be why this is not available especially when the listed owner … sends the invite to the co owner or else the shared / co owner cant even get their device connected… it makes ZERO sense… absoutely none… can someone pleas ESCALATE th is huge PROBLEM to someone who can get this taken care of ? really this is not good whatsoever, and unacceptable. I need to be able to have the SAME privileges and authority as the owner… I am CO owner… and the ONLY other SHARED account… so I hardly think this is impossible…

On my Android phone (Samsung S-8+) deleteing all Ring event history is simple enough (though not obvious).

  1. Open History

  2. Press on an event and hold until circles appear to the left of every event

3.Then go to and press the three verticle dots at the top, right of the screen. “Delete all” appears.

Press that and all historical events will erase

Note: The icon on the Ring app on the home screen will still carry a number of events at first. That will catch up after a couple of minutes.

1 Like

Thank you for the update indicating to “long press” on an event to get to the option to delete all. When I recharged my battery, the entire history of videos reloaded. The swipe right process identified on the Ring site did not work, but the long press did. I hope Ring will update their help information to identify the correct process to delete all videos.

Thanks for your answer. Worked perfectly.

1 Like

On Android, the delete all tool has disappeared again

Hi @Dvd! Try removing the Ring app from your mobile device, and reinstalling it. This will ensure it is up to date and optimally integrated with your phone. Please let us know if this works! :slight_smile:

The “Delete All” option is no longer available on my iOS app. I tried removing the app & reinstalling it & it’s still not there. Help!