Delay on connection or no connection when doorbell motion is triggered

When my front door camera motion is triggered and I get a notification on my phone and click to view, the connection is very delayed or never gets connected AND there is no recording of who triggered the motion.

Hi @Houselady! It sounds like there may be some connection concerns here. If the video is not connecting or recording, please ensure the RSSI, or wifi signal strength, is sufficient for video streaming. Check out our Community post about RSSI for tips on optimizing wifi signal.

Try also, uninstalling and reinstalling the app to see if this improves your connection experience. Let us know how this goes! :slight_smile:

Thank you for the reply. It’s typically not my wifi connection on my phone because I use my unlimited data plan instead of wifi. But I’ll review the recommendations.

Thank you.

@Houselady It’s not the wifi on your phone. It’s the wifi on the camera that connects to your home router that might be the issue.

Go to the device in the Ring app and select “Device Health” - look at the signal strength RSSI. I goes from 0 to -99. If its close to -99 then the wifi is bad. Tap the “?” next to the field to get an explanation of RSSI.

I personally do have a few second delay - I get the notification, tap it instantly, I’m taking to the Ring app but it doesn’t show me anything. If I wait 2-3 seconds then the recording is available (assuming you paid for a protection plan that records video)

1 Like

Thank you. I’ve checked the device health for the camera it is RSSI - 43 and the firmware is up to date. I’ll run some other diagnostics and refresh my connections at home to see if improves. Thanks again for the support.