Dead after power outage

After cutting power via the breaker to my doorbell to do some work, i powered the breaker back on and the device will not go into setup mode…
And yes:
Checked and theres power to the unit✔️
Pressed the setup button for 30 seconds✔️
Removed the device from my dashboard and tried adding it again✔️

Nothing ive done has gotten this thing to go into setup mode

This is the second device that this has happened to, the first was a spotlight cam and i just figured i was doing something wrong… is this a common occurrence with these devices?

Hi @Rayray2686. I have not seen this as being a common occurrence. Since you have tried all the basic troubleshooting steps I would have recommended and your Ring device is still unresponsive, the next best step is to reach out to our support team for further assistance. Give our support team a call at one of the numbers available here.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.