Dashboard Not Refreshing Cam Image

Same problem, for about 3 months now. It worked perfectly for the past 5 years and now the Dashboard just takes FOREVER to refresh. If I leave it sitting on the dashboard for 5-6 minutes, it’ll usually refresh most of my devices, but still not reliable. (even after checking live view of them)

Same issue as of 1/24/23

We had the same issue. I read all of these posts then we realized the new stick up cam was too far from our wifi router so we moved it to the other side of the garage. My go live view works now while only using mobile data and the preview now shows in the app when I open it. BIL just told us to buy the Ring wifi extender so we’ll be trying that too. Good luck!

Same issue starting end of Dec. '22. After a couple of weeks of the Dashboard camera views not updating, it worked for about a week, then, several days later, stopped working.
Even going to live view and returning to the Dashboard will not result in the latter updating, and the views can be 24 hours or older. Contacted support and, as they advised, deleted app data and cleared cache with no effect.
Reviewing this thread, it’s clear this has been an ongoing problem for a long time. Ring, when are you going to fix it? So far all I see is that you don’t have an update to share. Well, how about fixing the problem and sharing that?

1 Like

Same issue here. Dashboard camera views not updating as it should. It all started when it was updated to the latest app version (5.56.0) about a week or so ago. Now the Dashboard update it’s random from 15 seconds to 45 seconds to 3 minutes plus. Before the software update, it works perfectly and the Dashboard view is updated in few seconds once I open up the Ring app, now it’s just random. This is really important feature for me, please forward this to the correct team for a fix ASAP. This issue is happening on 2 iphone 12 running IOS 15.6.1

Things I have tried so far:
-Reboot both phones
-Reboot Wired floodlight cam
-Delete and re-install ring app on both phones
-Make sure settings are correct in the ring app
-Tried on 2 different Wifi connections as well as on Cellular connection
-Clear Ring cache

I really dont think the issue is with my phone or my network and I feel it will be pointless to call and spend time on the phone when they may just ask me to reboot this and that. Would one of the Tech here please forward this info to the appropriate team so they can look into it. Thank you.